[SOLVED] 3 minute Dapp - returns empty array


Doing the “Simple Dapp in 3 Mins”

Login works, but the array of transactions is empty.

I do have transactions in Metamask.
I double-checked everything, deleted the Moralis server and made a new one.
Server is on Mainnet and ethereum, Metamask is on ethereum.
No errors, but in the console at “user transactions” it says "length:0
My code is exactly the same as the example code.

Any help appreciated, i would really like to finish Getting Started :grinning:

Browser: Brave (also tried Chrome)
Windows 10

What is the server ULR?

1 Like

Hi dizid,

Are you referring to “Part 3” where you create a query on EthTransactions? When the user logs in Moralis will pull all their Ethereum transactions into the EthTransactions table. You can open the Dashboard to see them in “Browse” section. This is the data the query is looking through.

You’ll notice the query does the following

query.equalTo("from_address", user.get("ethAddress"));

This query is looking for all transactions where the from_address matches the Ethereum address of the logged in user… i.e. all transactions SENT by the user. If that address has not sent any mainnet transactions (only received) then this query would return no results.

Does that help? If not please post all your code, server details, and any error messages so we can better debug the issue.

1 Like

Hi Ivan,
The problem solved itself.

Server URL: https://kblfvedvp6gs.moralis.io:2053/server

BTW: thanks for getting me into Moralis!

1 Like

Hi mayer,

Thanks for your reply.

The problem solved itself, the transactions are now visible in the console.
I didn’t change any code or settings, but it works now

Maybe it takes a bit of time before the Moralis server gets the records into DB.

1 Like

Even if there are thousands of transactions to sync they should start show up pretty much right away (in batches)… oh well, glad it’s working now though.