Remix compile error SPDX-License-Identifier [SOLVED]

   
Hi :slightly_smiling_face:

Please. I had trouble making a smart contract.

babybaba.sol: Warning: SPDX license identifier not provided in source file. Before publishing, consider adding a comment containing "SPDX-License-Identifier: " to each source file. Use “SPDX-License-Identifier: UNLICENSED” for non-open-source code. Please see https://spdx.org for more information.

1 Like

Hey @Diamond

You have provided screenshots incorrectly.

But this error means that you have to specify SPDX license. Just add to the top of the code

Example:
//SPDX-License-Identifier: UNLICENSED

1 Like

just add this on top:

// SPDX-License-Identifier: MIT
2 Likes

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Sorry, my message is not displayed
I said the first case was resolved :worried:
He acted very strictly

36

@Diamond
So, the problem has been solved?

Unfortunately no :worried:
I have two problems
I uploaded a photo

Please upload your contract code :raised_hands:

Regarding debugging. If you are trying to debug it using our speedy-nodes - we don’t support that method.

1 Like

0x1b97f4b1ba923d1A98BC359f080180fbCf7615A4

I copied the contract from this

Regarding debugging. If you are trying to debug it using our speedy-nodes - we don’t support that method.

1 Like

In which network you are trying to debug it?

1 Like

BSC

I have only two errors
I want them to go away
I gave a photo
I also gave a contract

Uncheck the Generate contract metadata

1 Like

Actually it’s just warnings, which don’t have any affect to your contract. If you don’t have errors which don’t allow you to deploy contract - you can deploy it. I suggest you to start using truffle. We have nice tutorials about deployung using truffle:

1 Like

I will check tomorrow. Thank you my friend

We must be able to create my contract.
Because this contract blocks malicious robots and is very smart

1 Like

Did you successfully create my contract?