Rate Limited By Cloudflare

So, if I am rate-limited by cloudflare, does that simply mean that I need to upgrade to a paid plan? I don’t think we are hitting anywhere close to the limit of requests, so I am wondering if something else could be going on. Here’s the message:

Error 1200

Ray ID: 69bd4c497bdb57f1 • 2021-10-10 05:02:42 UTC

This website has been temporarily rate limited

What happened?

Too many requests for speedy-nodes-nyc.moralis.io. Try again later.

Please see https://support.cloudflare.com/hc/en-us/articles/360029779472#h_302a97f3-eba3-4c0a-a589-76ba95f60dcf for more details.

This doesn’t look like a limit directly from Moralis, how many requests did you do in a short period of time before you got this message?

Not sure. We used Moralis as a provider for hardhat and then ran several test transactions in a span of a few seconds, but it shouldn’t have been that many transactions. I’m not entirely sure what hardhat is doing behind the scenes

this rate limit may be gone automatically in one hour, but it doesn’t look like you did lots of requests

Yeah, I don’t think we did. The other thing is, the rate limit did go away in a couple minutes. We had several batches of tests that we ran consecutively, and it seemed sort of random as to when we would receive this error message. Sometimes we would run a batch of tests and then receive the message, and then on the very next batch, a couple minutes later, the message would not appear

It may be fixed now, can you check again?

It seems like that error isn’t showing up now, but we’ll let our script run for a bit to see if it appears again. I did notice an “Unknown block number” error a couple of times, but I am going to investigate that a bit first

Just started getting this error again- the Cloudflare rate limit

You mean are you seeing them now or you saw them like 8-9 hours ago?
asking to know if the problem is still present, we tried something ~7 hours ago.

I saw them shortly before posting that latest message. So, around 2 hours ago. They lasted periodically for around 1 hour (not on every request, but on some), and then we haven’t seen any in the last hour or so.

Earliest instance of this error message was: 2021-10-13 03:24:32 UTC
Latest instance of this error message was: 2021-10-13 04:15:58 UTC

It seems like this problem has been solved. Thank you @cryptokid! I will let you know if it appears again

1 Like