Rarible Clone Github

I found the files already created on Github, now I am trying to edit the page and view it hosted locally. When I host the front end files by themselves, I only get a blank screen with ~/ and a search bar. Is there a resource available that details how to test the the site?

Specifically, I am at the video where we build the smart contract, and I know we will have to test the site again soon. How do I host the whole thing locally? When I use the command python -m http.server , then go to, the page does not work. When I host it live from VSC the page is white with the symbols and search bar. The console on the page does not indicate any errors.

I apologize in advance if these are noob questions. This is my first web design project, I usually use C++ to code programs.

You could have started with simpler project.
You have to run python -m http.server 8000 in the folder where is your index.html file.

I agree, this was a massive undertaking. On the other hand I am learning a lot. I was able to host it from the directory with the index file in it. Now when I access it on chrome, it does not load the page and puts out an ERR_EMPTY_RESPONSE. The console says ‘crbug/1173575, non-JS module files deprecated.’ Have you encountered this before?

I didn’t encounter this before, google says this:

I had the same issue and the problem was with the URL, it was https://localhost:8000; in place of http://localhost:8000.

yes I have tried that as well as other solutions that google has presented. In the directory, there are only 4 files so I really cannot tell what the problem here is.

how do you access that file? the link should be something like

It gives me this link in the terminal http://[::]:8000/ but I have also tried , , and None of these are working.

you can put a simple asdafsdf.txt file in your folder and try to access it, also if you rename index.html to something else then you should see the directory listing when accessing

I put the text file in there and I cannot access that either. Its probably not the files I guess, its the way I try to access the file from the browser I think.

Im still really stuck on this part, here is a screenshot of the code and terminal

and here is what the page looks like when I try to access it

and this is what it looks like when I use VSC Live Server

what if you run: python -m http.server 82 for port 82?
for VSC live server it looks like it was run in an empty folder.
You have there a space in last directory name, but it shouldn’t matter

python -m http.server 82 worked! I appreciate the help. What was the issue there? Do i need to run it from a unique port every time?

I don’t know exactly what was the issue, some ports don’t work, but you should have received an error for that