Please Increase rpc.gascap

I am using Snapshot ( ) which uses Moralis.

Recently one of our Quickswap proposals wasn’t working on Snapshot. We traced the issue down to this Moralis node RPC error: “missing revert data in call exception”.

This error is caused by a read-only gas limit on the moralis archive node. Specifically the rpc.gascap setting.

Please increase or remove the the read-only gas limit on the Moralis archive node used by Snapshot.

The read-only gas limit on nodes can be controlled with the rpc.gascap limit.
From geth documentation:

-rpc.gascap value    Sets a cap on gas that can be used in eth_call/estimateGas (0=infinite) (default: 50000000)

That default of 50 million is too low. I suggest setting it to infinite or 1 billion. As an example Infura sets their gascap to 10x the current gas block limit. So that sets gascap to about 300 million for infra nodes on Ethereum. I think that is still too low.

See here the documentation of Infura on their gascap setting:
Please at least set the gascap setting to a value as high as Infura does.

I am not the only one having this problem. Another support topic made about it is here: Error 500: missing revert data in call exception

How do you know what is the current value that is set? On what chain are you referring in particular?

You could also contact snapshot to ask them if they can use infuria instead of us.

This is on the Polygon network.