OpenSea Plugin Error


I am following the tutorial on this link. I have a Moralis server running on the mainnet with ETH blockchain, have connected my Metamask wallet. and I also have an asset that I can see on OpenSea.

However, when I send the request to get an asset, I am getting the following error:

{"result":{"status":502,"data":{"error":true,"data":{"code":500001,"message":"No asset found","details":{"method":"getAsset","network":"main","tokenAddress":"0x495f947276749Ce646f68AC8c248420045cb7b5e","tokenId":"66783736535690128230155608175898390784774481541806029361024625891773343858689","error":"API Error 403: Unauthorized. Full message was..." }}}}}

Is there anything that I am missing?

I have the latest Moralis SDK (1.3.5 via npm) and I also updated my server to the latest version yesterday.

Thank you.

It may be a problem with the api key. You tried that on mainnet? Can you also try on testnet in case that you tried on mainnet?

I tried on both, the testnet and the mainnet, but had the same error.
I don’t have the OpenSea API key.

Is there any place where I need to use the Moralis API key to make this work?

Try Moralis API key from here and let me know if this works

P.C @cryptokid

@taha Any idea where do I need to use the API key?

I am using the react-moralis wrapper in the web app and I don’t see any parameter that will accept the API key.