One inch is not working (error 400)

HELLO Please i need help with 1inch

This is the link

moralis.js:26242 POST 400
makepay @ test.html:70

Make sure you have 1Inch Plugin installed on the server your dApp is connected to

That has been done before but i still have the error

The issue seems from your code then

I made sure to follow all the appropriate guide line…
This is the link

That is the link to the TEST

What could have been wrong in the code


Check if you got sufficient balance to make the swap

The issues seems to be insufficient funds

I thought it was until I sent 10 usdt worth of BNB in to my wallet and it still didn’t work

It doesn’t even pop up my meta mask for the swap.

And if you check the console log it kept bringing error 400. Kindly check using the link

I have more than enough bnb in the wallet, and it still not working

Something is wrong on your side that you need to check for. Testing on the link you shared works fine for me

Great… Thanks, I have seen the issue with the code.
The token I am trying to swap is not among the approved token.

I tried it with other tokens and it went through.

Do you have any idea how one can get a token to be listed and accepted for swap by 1inch??

I don’t know the exact procedure, it may be a requirement to have at least a particular value in the liquidity pool.

1 Like