Not seeing the changes after deploying with cli

I deployed a site to my server, and it says server deployed but when i check out the site url, the changes i made are not reflected yet.
Here is a snippet.
new code:
//importing moralis


Moralis.serverURL = “”;

old code

//importing moralis
serverUrl = “
appId = “a8RiGzJnX5H8DFKlnvanOzsL5UTfbak8oRzPwXWU”
Moralis.start({ serverUrl, appId});

but after deployment it still shows me this error after i run it

Uncaught TypeError: Moralis.start is not a function at main.js:4:9

I checked on server and the code was deployed, what can happen is that there is a cache on cloud flare level or on browser level and you could still receive the old version of main.js, you can force the loading of latest main.js by changing its name or by adding ?parameter=value at the end of main.js when is imported

Thank you, that worked worked but i later got an error from moralis.js
Uncaught (in promise) TypeError: Cannot read properties of undefined (reading ‘map’)
at module.exports (moralis.js:23890:16)
at moralis.js:3832:50
at tryCatch (moralis.js:23008:40)
at Generator.invoke [as _invoke] (moralis.js:23238:22)
at (moralis.js:23063:21)
at asyncGeneratorStep (moralis.js:22455:24)
at _next (moralis.js:22477:9)
here is the part with the error
module.exports = function (it) {
var own =; //error
return it === ArrayPrototype || (it instanceof Array && own === ? map : own;

and in web3.min.js file

heres the error
Uncaught (in promise) TypeError: e is not a function
at web3.min.js:2:26087
at web3.min.js:2:26968
at r (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/inpage.js:1:39277)
at s._handle (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/inpage.js:17:1969)

I would really appreciate your help if you can
here is the link if you can inspect it your self

this error seems to be from a chrome extension

you should also try to use a more recent version of Moralis SDK:
<script src="[email protected]/dist/moralis.js"></script>

this version 0.0.6 is super old

ok, i know its too much to ask but what can i do about that, i’ll still check it out though.

whats the reccent version?

you can try with version 0.0.184 first, lates version is 1.2.3

you can try to disable browser extensions

thanks, ill try that out and continue the thread.