Non ethereum enabled browser

Hey, I’ve been trying to get my personal Dapp working through Moralis but I’ve come across a problem.

When trying to login through Trust Wallet or Metamask on my Android phone I get the message “Non ethereum enabled browser”.

    async function login(provider) {
        try {
            let web3;
            if (provider == 'walletconnect') {
                const user = await Moralis.authenticate({ provider: provider });
                web3 = await Moralis.enableWeb3({ provider });
            } else {
                const user = await Moralis.authenticate();
                web3 = await Moralis.enableWeb3();
            alert("Logged In!");
        catch (ex) {

Anyone has an idea what I’m doing wrong here? It’s working fine on a PC with either wallet connect or metamask.

what do you mean by that?

If I use the Dapp browser in Trust Wallet (or metamask) I get this error. But if I use metamask on a PC it works fine.

I’ve tested the same code on a barebone site deployed on Vercel. It’s actually working there.

Does anyone know if domain and SSL are required for the Dapp browser in TW/Meta to work?

I heard that SSL is required for wallet connect to work

have u fixed it for mobile?

Yeah it was not having SSL that caused it.

can u please elaborate how u fixed i coudn’t get it.

I hosted it with an SSL certificate on Vercel and that worked.