NFT missing from BscNFTOwners table

Hi!

I have hit a problem with an address that doesn’t have all NFTs loaded into BscNFTOwners. My server is https://laeartv72t0b.usemoralis.com:2053/server. I have just a single user on this server. The wallet concerned has two NFTs (https://bscscan.com/address/0x17c823a15f176db4874f3e2c93a6c798805b60ac) but only one of these has been loaded to the BscNFTOwners table.

Any idea what might be happening here, I’m not sure where to begin my investigation?

Thank you!

Hi! Have you selected the network like this?

Hi Ivan,

Thank you for replying :). I have selected Bsc (Mainnet), both the NFTs are on BSC. Should I select Eth as well?

Thanks.

An update - I’ve added other users with other NFTs, including wallets that hold NFTs from the same contract as the missing item. They have worked fine, so it’s just that original user that is missing an NFT in the owners table.

Is there a way to trigger a reload of items in a NFT owners table for a given user?

Thank you!

1 Like

can you see any errors if you go to Logs in your admin panel?

Hi Ivan,

Whoops, may have replied to this twice by mistake :rofl:. Alas there is nothing in the logs.

I’d been working on a theory that the minting of the NFT was in the same block as the user first logging on to the server (and therefore may have slipped between ‘historic’ and watched for items). However there was actually a 20 minute separation.

I don’t know if it being the first item for the table could be an factor? I will try to repro this on another server. I was also considering using your deep index API and writing a reconciliation over the table. Not necessary of course, but might be a useful tool.

Thanks for your help.

Hi @keyoke

That issue was fixed at the latest update.
Please update your server

And let me know how it will work for you👷🏻‍♂️

Hi @Yomoo, you guys rock!! :muscle::muscle:

Thank you for doing that. I was testing with a new server at 0.0.247 and couldn’t reproduce the issue, so I guess that is why :).

Out of interest, what was the issue? Was it missing the first NFT when the owners tables are created, or was it something else?

I’ve upgraded my main server to 0.0.247 now. Did you expect the upgrade to pick up the missing NFT? It didn’t - I wasn’t expecting it to, if this only effects future items, but I wanted to mention it in case you expected it to fetch the missing item.

Thanks again.

Hi @keyoke

The dev team has fixed this bug. Yesterday I helped to do some debugging.
Therefore, this bug no longer exists on version 0.247.

Are you saying the update didn’t restore the missing Items? Try to sync them manually:

image

Let me know how it will work for you :man_mechanic:
Thanks!

Hi @Yomoo,

Great work on the fix :man_mechanic:. Exciting - I didn’t know I could run that job manually! I get an error though on the Job Status log saying “Address is required”. Do you know how I get an address into this run as a parameter (sorry if I am missing something obvious :smiley:)

Thank you!

Oh, sorry, my bad

You can sync manually only provided address. So, if your table missing info about a user, use this plugin and provide wallet. After you will see status “SUCCEEDED” in logs you can delete manual syncing and watching. Please try this method :man_mechanic:

Hi @Yomoo,

Thank you very much for the advice. I tried that as you suggested but it didn’t bring in the missing NFT. Would I expect adding that plugin to update the watched addresses table?

At the same time I am also experiencing problems with BSCTokenBalance, which isn’t updating the token balance for a user. The transactions are appearing as expected in BSCTokenTransfers but are not rolling up in every case to the BSCTokenBalance table (for some they have, some they haven’t). I notice this is the same as for the BSCNFTOwner, as the missing NFT does appear in the BSCNFTTransfers table but not in the BSCNFTOwner table.

These two issues are both on the same server. I can’t see anything in the logs to indicate an error. Is it possible there is just an issue with this server instance?

Thank you very much! :slight_smile:

Hi @Yomoo,

I’ve been able to reproduce the BscTokenBalance issue on a another server (https://bttcjtdkuqd4.moralisweb3.com:2053/server).

The transaction is this one here: https://bscscan.com/tx/0xecef8a9a6e7b3e351b2c59037e86d671be77789f2508d50b28ab0c842bb8a322.

The txn is noted in BscTokenTransfers but does not update the balance in BscTokenBalance. I suspect this is something of a new issue, as this isn’t something I’ve ever experienced in many test cycles on an older Moralis server running over testnet.

Are you able to have a look please? My dapps rely on BscTokenBalance data and don’t work without it :(.

Thank you very much!

Hi @Yomoo, FYI I thought it would be helpful to list all this down on a github issue ticket, so I’ve done that here: https://github.com/MoralisWeb3/issue-tracker/issues/90.

Thanks again!

1 Like

Hey @keyoke

Thank you for reporting :raised_hands:

We will check :man_mechanic:

Thanks @Yomoo!

As I mention in the issue log on github I’m happy to help any way I can, just ask :+1:

Should be fixed as communicated in GitHub, thanks for reporting!

Amazing support, thank you @ivan and @Yomoo and the team at Moralis!

1 Like