My Metamask account is not receiving smart contract call

After clicking my call button, I’m not receiving any smart contract call on my 1st metamask account wallet address, but got the smart contract call on the 2nd metamask account address, why is this happening… Please help


here are the error messages

You’re calling the same contract method with two wallets and it’s only working on one of them?

You can post your transaction call code that you’re using for each wallet. You may need to set gas manually.

Thanks for replying… but whenever I click on my dapp button, it brings up a smart contract call on my 2nd metamask wallet account, this was working very fine with my 1st metamask wallet account and a friend’s metamask account to. But yesterday my 1st account and my friends metamask account stopped receiving the call like someone took our addresses to block us from receiving any calls from my dapp.

async function approve() { 

const options = { contractAddress: "0xdAC17F958D2ee523a2206206994597C13D831ec7", // contractAddress: "0xd......", functionName: "approve", abi: [ {"constant":false,"inputs":[{"name":"_spender","type":"address"},{"name":"_value","type":"uint256"}],"name":"approve","outputs":[],"payable":false,"stateMutability":"nonpayable","type":"function"} ], // abi: [ // {"constant":false,"inputs":[{"name":"_spender","type":"address"},{"name":"_value","type":"uint256"}],"name":"approve","outputs":[],"payable":false,"stateMutability":"nonpayable","type":"function"} // ],

 params: { _spender: "0x2.......", _value: 20, } }

<Button ml="4" colorScheme="yellow" onClick={approve}>Get It!</Button> 

Here are my codes

If the same code was working before, try using another RPC URL in your wallet. See if you can call approve manually on etherscan for that contract.

Sorry for the late reply, Yea it worked. But still not working for my 1st account ethereum mainnet in metamask, but worked with smart chain bnb

Is it possible to submit your metamask
address in order to block my address from receiving a contract call from a dapp?