Moralis not indexing some NFTs in a contract on polygon

Hi everyone,

I have a contract address on polygon - 0x0a6f27f77b8056d5999e3c7beb631f0cd888194c
This contract currently has 61 NFTs as seen here -

Moralis was indexing NFTs properly up until yesterday and the API is responding with 58 tokens in the contract address -

curl -X 'GET' \
  '' \
  -H 'accept: application/json' \
  -H 'X-API-Key: ###'

But after I minted token number 59, 60 & 61, Moralis has not updated the index for over 1.5 days now. (usually took a few mins to update index).

Is there any way i can force refresh the indexing process?

I’ll check later today.

Thank you for the quick response. Really appreciate your help on this! :slight_smile:

it looks like I get same behaviour as you describe, we’ll have to investigate, thanks for reporting

Is there a quick temporary workaround or something i can do in the mean time to resolve this issue? Getting quite a lot of paying users reporting that people are unable to see their NFTs in their wallet.

this means that you have this problem with multiple smart contracts?

Nope, just multiple token ids on this specific contract. I haven’t tried testing on a different smart contract. Would this bug be resolved if i create a new similar smart contract which people can re-mint their NFTs on?

I was asking because what you said sounded like you have this problem for more than those 3 NFTs that are missing on that specific smart contract.

Ah, no. Just these 3 token ids for now. Is there a way to manually refresh the indexing for these tokens in the mean time?

I don’t know of an easy way, you could try to add those entries to NFT owners manually, but I don’t know how well it would work, or to automatically insert data for those 3 cases from code by hardcoding some data there on response before showing data to interface

Alright, sounds good. Thanks for the heads up! Would it be possible to provide a rough estimate when this issue will be resolved? (hours/days/weeks/longer). It’ll help me come up with a way to plan a workaround for the bug in the mean time.

For now I assume less than hours until it will be fixed.

Amazing, thank you so much!

it looks like it works now

Yep, verified. Thanks!

Hey! it seems like the indexing is broken again. I can see 61 token Ids now whereas it should be 63.

curl -X 'GET' \
  '' \
  -H 'accept: application/json' \
  -H 'X-API-Key: ###'

63 Token IDs -

yes, I can confirm that it doesn’t work with id 62

I’m not sure if this is the same problem, but currently I do not see the correct Polygon NFTs when I call this function in the API (using React but also tested REST API in console)

const nfts = await Web3Api.account.getNFTs({ chain: "polygon" });

It returns zero results, even though it’s showing up correctly in dashboard

This call correctly returns all the transactions, however.

await Web3Api.account.getNFTTransfers({ chain: "polygon" })

I also tried the specific contract, but get back zero results with the status “SYNCING”

      const nfts = await Web3Api.account.getNFTsForContract({
        chain: "polygon",
        token_address: "0x2953399124f0cbb46d2cbacd8a89cf0599974963",

Yes, ID 62 & 63 are currently not indexed & missing from the API response. I believe this is the same issue I faced earlier?

it looks to be related to same problem