Moralis Local server - setup issue

HI there, In the process of setting up the local Moralis server - basically following this guide even though it seems a little outdated.

I get this error on start:

throw err;

Error: connect ENOENT redis-cli -u redis://USER-HIDDEN*
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1278:16)
Emitted β€˜error’ event on RedisClient instance at:
at RedisClient.on_error (C:\Moralis_Web3\server\parse-server-migration\node_modules\redis\index.js:342:14)
at Socket. (C:\Moralis_Web3\server\parse-server-migration\node_modules\redis\index.js:223:14)
at Socket.emit (node:events:513:28)
at emitErrorNT (node:internal/streams/destroy:157:8)
at emitErrorCloseNT (node:internal/streams/destroy:122:3)
at processTicksAndRejections (node:internal/process/task_queues:83:21) {

My .env has the Redis line data from the redis website copied from here:

ps. I tried the redis entry without the β€œredis-cli -u” part also - same result
Any idea where I am going wrong?

Hi @MS_42

It could be possible that there is a local network issue. If you have an VPN please try disabling it.
Also, check online if your operating system requires any additional updates to connect to Redis. Some cases your connecting request could be blocker by your network firewall.

Thanks John, I’ll check that

1 Like