Moralis Live Query and Database Query is not working properly

Hi Moralis Team, We are using a Moralis V1 SDK for our own event listener architecture. We use Moralis Live queries and queries for fetching the new events added to MongoDB.

But sometimes the Moralis Live Query service is not sending any data when a new event is added to MongoDB and also when doing a manual database query via cron jobs, even this action doesn’t provide the required data properly. After the server restart which also re-initializes the Moralis SDK, everything works properly again.

Can you guys look into this issue as a top priority ? we are facing this issue on both testnet and mainnet Dapp servers.

And also we got this error randomly and not sure about the impact

Moralis SDK Core Error: [C0006] Request failed: timeout of 10000ms exceeded
    at RequestController.makeError (/Users/venkateshrajendran/Documents/Work/OP Games/oparcade-backend/node_modules/@moralisweb3/core/src/controllers/RequestController/RequestController.ts:84:12)
    at RequestController.<anonymous> (/Users/venkateshrajendran/Documents/Work/OP Games/oparcade-backend/node_modules/@moralisweb3/core/src/controllers/RequestController/RequestController.ts:52:26)
    at step (/Users/venkateshrajendran/Documents/Work/OP Games/oparcade-backend/node_modules/@moralisweb3/core/lib/controllers/RequestController/RequestController.js:44:23)
    at Object.throw (/Users/venkateshrajendran/Documents/Work/OP Games/oparcade-backend/node_modules/@moralisweb3/core/lib/controllers/RequestController/RequestController.js:25:53)
    at rejected (/Users/venkateshrajendran/Documents/Work/OP Games/oparcade-backend/node_modules/@moralisweb3/core/lib/controllers/RequestController/RequestController.js:17:65)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)


You are using a self hosted parse server?

That timeout of 10s can be to an API endpoint

We are using the Moralis hosted dapp server.

What about the improper functioning of live queries and queries services/APIs ? I am not sure about the reproducible steps but it happened 3 times in our servers where it requires a server restart to re initialise the Moralis sdk to get a proper behaviour

I don’t know what could cause that now. When it happens if you make a normal query with the SDK still doesn’t work until you restart the server?

How many live query connections are made?

When I tried fetching some data based on certain filters, I don’t get those data as a response while using the queries.

we might have 10 Live Query connections and it was working well for us for so long. This kind of issue has occurred this week

we didn’t change anything recently for the servers

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.