Moralis deploy --d doesn't seem to work

When i copy-paste the first part of my server url after ‘moralis-admin-cli deploy --d’ it still asks me to choose a server numerically

does anyone know why? or is this an issue?

Thanks we will check!

This feature should work.
Please provide your server URL.
Also provide screenshots of the problem you are experiencing.


full server url

is this same issue as your other thread?
In that case paste this info there and we close this one so we have 1 thread only

this is a different issue as this issue makes it so that i can not automate the deployement, the other one was the site not showing up when doing it manually

Can you try with a single dash: -d or --moralisSubdomain. I see there is an inconsistency in the docs. We’ll fix that

this is the github actions script:

the cli input at the end gives the following problem:

  • it still asks which server i want to deploy to
    it does not select the right server eventhough i gave it the url with --d

after changing to -d it still does not work

try with only the subdomain and leave out “”, so if you previously tried: “-d”, try only: “-d mySubDomain”

This returns the same issue, where it does still ask for the domain

i don’t know if the issue is akin to the one with the create server where there was an issue with choosing the evm providers where there was an issue with the implementation of the command itself

neither way works, aside from that it says subdomin instead of subdomain


I have tried near-on every possibility

it does not read it when i have the question answered with echo or printf

ok thanks we will cehck this

Sorry, my bad. Should be this structure
No port, no protocol just the structure above.
Please update to the latest version of the CLI and let me know if the problem persists.

1 Like

it still does not work and keeps asking for the subdomain, however the typo also still persists

Bug is now fixed and should work if you update to the latest version of the cli. Please verify, and thank you for your patience

i still get the same issue after doing npm update moralis-admin-cli

running it in vs code in stead of rider i still get the same issue so it is not caused by the ide

and no worries, i love using the tool so keep on truckin’ cuz im just trying to help out

1 Like