Moralis.Cloud.httpRequest Problem on Singapore Region

Call httpRequest, get follow error,
{errno: -3001, code: 'EAI_AGAIN', syscall: 'getaddrinfo', hostname: ''}

This (may) happens only on server in Singapore region, I’ve tested same function call on Sanfransico, Bangalore region, but there were no problem.

My cloud function code looks like this:

Moralis.Cloud.define("requestTest", async (request) => {
  const logger = Moralis.Cloud.getLogger();
  return Moralis.Cloud.httpRequest({
    url: ''
  }).then(function(httpResponse) {'Reply...' + JSON.stringify(httpResponse));
    return httpResponse;
  }, function(httpResponse) {
    logger.error('Error...' + JSON.stringify(httpResponse));
    return httpResponse;
1 Like

If you try multiple times or with same url or with different url you get same error?

When using on Singapore region,

url: --> ok
url: --> error
url: --> error

here is Korea, and if you need more domain test, let me know :slight_smile:

I tested with a server from Singapore and it looks like I get same error

Yep, I thought it might be related with that region’s router or dns config matter

Is this issue scheduled to fix for near future? :wink: I need Singapore region because of the network latency from here, Korea.

I don’t have un update yet.

we need your server url in order to update the dns settings

Many thanks to your team’s efforts. My server url is,
if wild card is possible, *, *
if only specific domains are possible,,

Thanks in advance :heart_eyes:

No, that is not what I mean, I mean what is your Moralis server subdomain that you use.

Oops, :laughing: for now,,

If so, whenever creating a new server at Singapore region, Will I have to let you know?

for now it looks like we update the dns configurations per server to fix that problem

Got it, many thanks! :heart_eyes: If you done, let me know.

it should work now on those 2 servers

I’ve tested,

on, same error occurs
on, same error occurs

dashboard logs,

2022-01-03T18:44:20.940Z - Request failed with response code {“errno”:-3001,“code”:“EAI_AGAIN”,“syscall”:“getaddrinfo”,“hostname”:“”}

Thanks for your concern!

Do I have to use bangalore region? Within a week, I have to decide which region to deploy a production service.

1 Like

it should work now on both of those servers

OK, now it works!

Thanks a lot, by the way, when I deploy production server at this Singapore region, who do I tell this assist to? At this thread or my dedicated manager of Moralis?

you can write on this thread

Got it, thanks! :heart_eyes: :heart_eyes:

I have the same issue with on could you fix it for me @cryptokid