Moralis Binance speedy node (paid) is not working (testnet Ws)

i paid for a full year pro plan
and i am using the quick nodes of Binance testnet and mainnet

today i tried to deploy for Binance testnet using truffle, i used the Ws Binance testnet node and it keeps getting stuck after compiling
it was working fine before, after i run command truffle migrate --reset --network bsctestnet i will compile then stuck at that for ever

and i dont use HTTP cuz it does not work good with truffle and keep giving me timeout (ETIMEOUT)

so we used Ws for a while now and suddenly it does not work

what’s the solution to Ws binance quick node pro plan??

is there any help please ?

can you use other RPC node in truffle, like the official RPC node from Binance to see if it works?

does it deploy more than one contract in truffle?

you tried multiple times and it got stuck every time?

with Binance RPC node i get timeout but it does not stuck after compilation

but we paid pro plan to use the speedy Binance node (mainnet & testnet)

same if i try to use Moralis HTTP speedy node it will work and timeout
but we used to use Ws node but suddenly its getting stuck

i just tried the Ws Binance mainnet node and it worked perfetly

only the paid Binance testnet ws is broken
still stuck after i run the command (After compiling)

it does not even give me timeout error
just stuck

several employees tried to deploy using paid ws Binance testnet node and we all got stuck at the same problem

I got some problems with web sockets and bsc testnet too, I get timeout sometimes when I try to use web socket and get current block number

sometimes it works, but most of the times it looks like it doesn’t work

yes, and HTTP also timeout with truffle
whats the solution ?

does it stuck after compiling ?
or only timeout ?

I didn’t try to compile, I tried only a simple python script to get current block number and I got timeout

I don’t know what is the solution now, the team will have to look to see if there is a solution

if you try multiple times it may work once, but this is not a good solution

okay thank you, if you create a contract and deploy using truffle to Binance testnet ws node (paid)
it will get stuck at compile or timeout

please update me ASAP

Thank you

Any new updates on this issue? I am also running into the stuck connections on bsc testnet on the free version via websockets. It seems to be getting worse and worse. I am getting tired of constantly refreshing the page till it connects and then runs the blockchain calls like normal. Please fix this issue Moralis :pray:. Thanks!

1 Like

I don’t have new updates now on this issue

well, the company i work in paid full year pro plan (around 600 USD) for a service that we dont get
always laggy or stuck or broke

hope they fix it soon
please fix this issue Moralis , Thanks

@ZaidHalim, @surgery18, can you try again now to see if it works better?

YEP! It looks like it is working much better now. Thank you! If I run into the issue again, I will let you know.

1 Like

yup its working great, thank you @cryptokid
really great support

1 Like