Moralis-admin-cli deploy NFT (following youtube-video)

I want to make NFT’s using Moralis, following this yt-video: https:// www .youtube. com/watch?v=tBMk1iZa85Y)

at timestamp 31:18 the coder uses deploy moralis-admin-cli- deploy

After choosing the server I get this error:

What server do you want to connect to?: 0
En error occured when trying to deploy
Error [ERR_FR_MAX_BODY_LENGTH_EXCEEDED]: Request body larger than maxBodyLength limit
at RedirectableRequest.write (C:\Users\Vincent\AppData\Roaming\npm\node_modules\moralis-admin-cli\node_modules\follow-redirects\index.js:102:24)
at FormData.ondata (internal/streams/legacy.js:20:31)
at FormData.emit (events.js:400:28)
at FormData.emit (domain.js:475:12)
at FormData.CombinedStream.write (C:\Users\Vincent\AppData\Roaming\npm\node_modules\moralis-admin-cli\node_modules\combined-stream\lib\combined_stream.js:138:8)
at DelayedStream.ondata (internal/streams/legacy.js:20:31)
at DelayedStream.emit (events.js:400:28)
at DelayedStream.emit (domain.js:475:12)
at DelayedStream._handleEmit (C:\Users\Vincent\AppData\Roaming\npm\node_modules\moralis-admin-cli\node_modules\delayed-stream\lib\delayed_stream.js:82:15)
at ReadStream.source.emit (C:\Users\Vincent\AppData\Roaming\npm\node_modules\moralis-admin-cli\node_modules\delayed-stream\lib\delayed_stream.js:29:19) {
config: {
url: ‘’,
method: ‘post’,
data: FormData {
_overheadLength: 280,
_valueLength: 40,
_valuesToMeasure: [Array],
writable: true,
readable: true,
dataSize: 0,
maxDataSize: 2097152,
pauseStreams: true,
_released: true,
_streams: [Array],
_currentStream: [DelayedStream],
_insideLoop: false,
_pendingNext: false,
_boundary: ‘--------------------------095572108844088954318667’,
_events: [Object: null prototype],
_eventsCount: 3
headers: {
Accept: ‘application/json, text/plain, /’,
‘Content-Type’: ‘multipart/form-data; boundary=--------------------------095572108844088954318667’,
‘User-Agent’: ‘axios/0.21.4’
(goes further but can only post two links as a new user)

please help me out :slight_smile:

You need a smaller folder to upload, it has a limit of 50MB, your folder should have less than 20MB to work with no problems.

what folder is meant here, because my folder that i use contains 4 files (not more than 200 kb).


if you don’t specify a folder as parameter it will try to upload current folder from where you execute that command, maybe you were executing the command from a bigger folder

1 Like

How do I change the folder or specify it? In the video the guy is not specifying the folder either though.
Sorry for noobish questions.
Tried moving everything to a smaller folder but didnt help.

moralis-admin-cli deploy --p C:\myDapp\

1 Like