Module not found: Can't resolve '@web3auth/web3auth'

Module not found: Can’t resolve ‘@web3auth/web3auth’ in '/Users/user/dev/project/node_modules/moralis/lib/browser/Web3Connector

Which package should i add temporarily to remove the warning, until it gets fixed?
yarn add @web3auth/web3auth and yarn add @web3auth gives me yarn errror.

You sure? what error did you get?

I can find @web3auth/web3auth here in NPM

It’s also documented in web3Auth’s GitHub

Had to update my node to >=14.17.0. Sorry :3


I’m getting this same error on my vercel hosting.
Can you maybe share some more details about the solution?

Same error here, is there a resolution for this?

1 Like

hello I got the same error I ran npm I @web3auth/web3auth to install the @web3auth/web3auth but I got another error. please take a look at the screenshot of my terminal and advice me on what else to do. i am a newbie and would appreciate instructions in plain language

Any solution on this?

I’m having the same error when building a react app.

After installing the package with npm I’m getting this error now:

ModuleNotFoundError: Module not found: Error: Can’t resolve ‘./build/Release/ecdh’ in ‘/Users/…/app/node_modules/@toruslabs/eccrypto’

what version of react, react scripts and node are you using?

I was finally able to pull it out after some days of trial and error.
It worked after upgrading the next version from 10.x.x to 12.1.6.

I think the problem was due to the bnc-onboard library.