Metamask not popping up

Yesterday Its working fine. and ended @ I CLONED RARIBLE IN 24H - Linking database tables [PART 12] Successfully mint and finishes just like intended on the tutorial

but when I tried to resume my work today, metamask won’t pop out

Hi @suntay44

Please always try to provide us as much info as possible (code, github repo, server subdomain, steps to reproduce the error) . We can’t help you by debugging your screen :raised_hands:

I haven’t uploaded yet in the repo, but my code is the same as in the tutorial. I also followed the part 7.5 and there are updates and changed it accordingly. even my cloud functions is working properly.

That is why I wonder if metamask is currently down or having problems ?

Metamask works just fine. Looking forward to see your code

I tried to put alerts in between to check where the code breaks on debug 1 alert it works fine, but on debug 2 it stops there. Even when I remove Debug 1 it doesn’t alert on debug 2.

createNft = async () => {

    const CheckName = Moralis.Object.extend("Nft");
    const query = new Moralis.Query(CheckName);
    const object = await query.first();
        alert('NFT Already Exists');

        if(nftFile.files.length == 0){
            alert("Please select a file!");
        } else if (nftNameField.value.length == 0){
            alert("Please give a name to your NFT!");

        alert("DEBUG 1!");
        const nftFileMint = new Moralis.File("nft.jpg", nftFile.files[0]);
        alert("DEBUG 2!");
        await nftFileMint.saveIPFS();

        const nftFilePath = nftFileMint.ipfs();
        const nftFileHash = nftFileMint.hash();

        const metadata = {
            name: nftNameField.value,
            description: nftDescriptionField.value,
            image: nftFilePath,

        const nftFileMetadataFile = new Moralis.File("metadata.json", {base64 : btoa(JSON.stringify(metadata))});
        await nftFileMetadataFile.saveIPFS();

        const nftFileMetadataFilePath = nftFileMetadataFile.ipfs();
        const nftFileMetadataFileHash = nftFileMetadataFile.hash();

        const nftId = await mintNft(nftFileMetadataFilePath);

        const nftItem = Moralis.Object.extend("Nft");

        // create NFT item in web
        const item = new nftItem();
        item.set('name', nftNameField.value);
        item.set('description', nftDescriptionField.value);
        item.set('price', nftPriceField.value);
        item.set('type', nftCardType.value);
        item.set('status', nftStatusField.value);
        item.set('nftFilePath', nftFilePath);
        item.set('nftFileHash', nftFileHash);
        item.set('metadataFilePath', nftFileMetadataFilePath);
        item.set('metadataFileHash', nftFileMetadataFileHash);
        item.set('nftId', nftId);
        item.set('nftContractAddress', TOKEN_CONTRACT_ADDRESS);

        alert('Minted Successfully!');


        user = await Moralis.User.current();
        const userAddress = user.get('ethAddress');

                case "0":
                case "1":
                    await ensureMarketplaceIsApproved(nftId, TOKEN_CONTRACT_ADDRESS);
                    await marketplaceContract.methods.addItemToMarket(nftId, TOKEN_CONTRACT_ADDRESS, nftPriceField.value).send({from: userAddress});
                case "2":
                    alert("Not yet supported!");


Is there new updates regarding:

        const nftFileMint = new Moralis.File("nft.jpg", nftFile.files[0]);
        await nftFileMint.saveIPFS();

server subdomain would be:

it is stopping @ await nftFileMint.saveIPFS();

Could you send me a screenshot of the response for request which is called after nftFileMint.saveIPFS()


I’ll try to restart my mac

my guess is right, something is slow. I tried to create again and wait for about 10minutes metamask shows up. I don’t think its my internet I speed test and working great. Could it be related to the moralis server? because the minting that took 10minutes is still in pending.

because this is the current situation in my server without any requests happening i’m on idle