Metadata is not returned properly by getTokenIdMetadata method

Hi, I have a production app (deployed on bsc mainnet) and currently it experience some issues with nft metadata. They are null right now, but couple days everything worked fine, suddenly yesterday evening stopped working as expected. Should I somehow resync those data or is there any other known solution how to fix this. Probably this method getTokenIdMetadata returns wrong metadata. tokenUri returned by this method is a fine. File with metadata is accesible, but metadata field is still null.

Here is example response which represents this issue:

  "token_address": "0x65f006ab6bcaaab15986f6e131dcc21210fac068",
  "token_id": "12",
  "amount": "1",
  "owner_of": "0x9aad909c83656c544b38291f48889bb894c59059",
  "block_number": "13058145",
  "block_number_minted": "13056224",
  "contract_type": "ERC721",
  "name": "VMint NFT Token",
  "symbol": "VMint",
  "token_uri": "",
  "metadata": null,
  "is_valid": 0,
  "syncing": 2,
  "synced_at": "2021-12-02T19:26:12.744Z",
  "frozen": 0

I appreciate quick help as my app is already accessible by our users.

1 Like

thanks for reporting, we are going to investigate

@cryptokid any progress on this ?

I don’t have an update yet

@cryptokid Hey mate, any info about this issue ?

we are investigating, we don’t know yet what happened

I see that metadata are back, but can you share any thoughts what happened with it ?

it wasn’t a problem on your side, it looks like it was something related to Moralis side

this problem randomly exists in many different nfts and accounts, do you have this issue resolved on your side or no ?


I have paid for the pro plan, can I get a support here ? I am starting to think that you do not know what this problem is about and I am in situation where app is served for end users and they do not see propelry theirs nfts.

we are working on fixing the problems with NFTs


Now I cannot fetch any data about this nft.

Moralis.Cloud.define('getMetadata', async (req) => {
  const res = await Moralis.Web3API.token.getTokenIdMetadata({
    chain: '0x38',
  	address: '0x65f006ab6bcaaab15986f6e131dcc21210fac068',
  	token_id: '30'
  return res;
  "message": "No metadata found! Try again later",
  "name": "Error",
  "stack": "Error: No metadata found! Try again later\n    at handleError (\n    at async eval (eval at <anonymous> (, <anonymous>:9:35)"

ok, it doesn’t work for me either, it looks like this was a recently minted token from ~1 hour ago

@cryptokid This was minted couple hours ago

@cryptokid that is right, on blockchain side everything works as expected, only api still does not have this data

Yes, it is only that I didn’t see that transaction from hours there, but anyway it should work on api and it doesn’t.

Thanks for sharing imformative information.


this one in particular works now