Issue when building rarible from the videos

I have cloned from get hub and watched all the videos , with using all the steps to build the marketplace . saving profile works and sign in works . However, when i start to create , this error get on the console Image attached

What could be the issue ?

Hi, you need to create own server and use own server URL, not reuse the one in the video


Hello Ivan , I have changed it multiple times and retried to update and change the server and i still get the one from the video !!!

Hi @Mintin,

Did you try hard refreshing the browser before running the code? Because browsers tend to use the same code when not hard refreshed. Hard refreshing -

  1. Windows users: hold down Ctrl and then press F5 on your keyboard.
  2. Mac users: hold down Cmd and Shift and then press R on your keyboard.

Do let us know if the issue persists and also let us know your server URL in the next follow up response.

Hope this helps.


Hi Malik,

Thank you for the response , I have did what you asked , which led to unable click on any buttons for some reason with .
Below is the images error from console

Server URL : Moralis.serverURL = ‘


You cannot just clone the Github and make it work, there are serveral other steps

  1. You need to setup the cloud functions properly in Moralis server
  2. you need to enable plugins in the server
  3. you need a local blockchain
  4. you need to import some of the accounts into metamask for payment
  5. you need to setup truffle
  6. configure connection between the local server and the moralis server using frps
  7. you need to compile and create the proper contract addresses

i might have missed some other things… btw the cloud function provided by the github is outdated, some of the feilds has been renamed by moralis so u need to edit those accordingly

Hi ,

Thank you for taking your time to respond to this issue ,I have worked through the video for the steps :slight_smile:

  • I used the GitHub morales cloud functions . Im not sure if the changes for the filed is about “NFTTokenOwners” ?
  • The Plugins has been added from the server
  • Using Testnet server
  • Local blockchain : using Ganache
  • Connected custom RPC on Metamask with Ganache URL.
  • Imported the Private key from Ganache to Metamask
  • Truffle is setup
  • proxy FRPS is connected
  • compile an create the proper contract used with " truffle migrate , and truffle migrate --reset "commands on terminal

So far when i open the frontend not the styled one . I can edit profile , i can create item and it shows in the server it is created . but i can not see my items .

Using styled Frontend , i can connect to my Metamask , however , non of the buttons are clickable , which it used to work before doing hard refresh .

Hope this help and help others who has the same issues :slight_smile:


Could you open your chrome console and see if you have any errors for which the frontend stopped responding.

make sure that you have EthNFTOwners table in your cloud codes.i had that mistake and It did not show also Items.

did u get passed this point?

yes actually I deployed also contracts on binance smart chain testnet , there is no problem until now :slight_smile:

@ aliekber1976 nice thats crazy

1 Like

I think Moralis is crazy :slight_smile:

1 Like