Issue querying transactional data past a particular offset

Hi, I’ve been using Moralis to query both transactions and balances data for a while now and recently stumbled across an issue. When I try to query data using the following parameters:
Chain: polygon
Offset: 12000
Limit: 500

I end up getting status code of 500 and with no reason, it just says internal server error. I have included a test file in python below so you can try run it to see it happening (you have to add your own API_KEY). Does anyone know what I can do as I’d like to continue extracting data for this address.

import requests

address = '0x777Ad55EFc465052d6A4AB7bc75B6A15175bB399'

headers = {
    'accept': 'application/json',
    'X-API-Key': 'API_KEY',

params = (
    ('chain', 'polygon'),
    ('offset', '12000'),
    ('limit', '500'),

response = requests.get(f'{address}',

print(f'Status code: {response.status_code}\n'
      f'Reason: {response.reason}')

Thanks in advance,

FYI: Setting to the limit to say 50 sometimes works but if i adjust the offset to 12050 it goes back to giving the same error.

I ran another check to see if it’s still happening and unfortunately the error still persists. Does anyone know what’s happening and potentially a way to fix it?


Is there any further detail other than Internal Server Error error?

your query looks correct although seems like the offset is really big :thinking:

we will have to investigate, it is clear that it is related to that offset


I have managed to extract data for addresses with an offset of over 1,200,000 (for BSC) with no issues whatsoever. I am unsure as to why this one in particular (which is at a much smaller offset) is having issues. Thanks for looking into it, greatly appreciated.

It gives no other information, just gives a status code of 500. This happens when I try it from it from moralis admin as well.

Hi, are there any updates with regards to this?

I don’t have an update now.

1 Like

Hi are there any updates with regards to this? Is it possibly an issue that becoming a premium user would solve?

I’ll ask again about this, now it looks like it gives a timeout. Becoming a premium user would not solve this.

1 Like