How to run NFT Marketplace using Moralis in visual studio on linux?

Hello guys, I want to launch this NFT Marketplace:
I know linux with visual studio.
I heard that you need to run it with apt. Can someone tell me in detail what to prescribe, fix?
How can I run it?

1 Like

Hey rom, to run the app you will need application Id and server url. To get those you have to signup . Here a doc how to create a server

1 Like

This is all I have. I’m stuck on this video at 7:06

Are you able to get your application Id and server Url from your server? If so all you need is add them to your .env file. If you are getting errors in running the app pleases send me error screenshot, so I can help you well.

Have you installed yarn? Installation | Yarn - Package Manager (

Hey @rom use sudo since it’s permission issue :raised_hands:

I re-read everything, tried it, it does not work on linux

How to solve this permissions problem?

One devops tells me this: You are installing with apt in their yarn video.

I’ll repeat my question (problem):
I have linux with visual studio code installed.
How to run this project in this configuration? :

Guys, I understand that you understand this issue, please write in more detail.
Thanks in advance!

Add sudo in front of the install command to get past the permission denied error.

I installed Yarn, but now it won’t start.
Here is the log after installation:

Now, when starting, “yarn start” gives an error: ERROR: [Errno 2] No such file or directory: ‘start’

Have you run yarn install first?

I attached the log to the file, see if you are a programmer, please.

:thinking: hmmm I can see, you can able to install yarn.

You should be in the Nft Marketplace folder to run yarn install. . I think this will help you switching directories.

yes, I installed yarn by doing these commands in sequence:

curl -sS | sudo apt-key add -

echo “deb stable main” | sudo tee /etc/apt/sourc

sudo apt update

sudo apt install yarn

sudo apt install --no-install-recommends yarn

And to make sure that it is installed and which version we do this:
yarn --version

now throws these errors after installing Yarn:

Run yarn install. Looks like you have added some additional packages.

1 Like