How to get email when using Web3Auth?

How to get the user’s email when they signup using Web3Auth?

I think that a user doesn’t need an email when he authenticates with a wallet.

I mean when they signup using gmail/twitter or some other service

In that case, if you make that work, the email should be saved in db in User table

Moralis released this integration with Web3Auth a few days ago.

When I’m signing up using Gmail, I am unable to view the email in my database. There is no field for it

Ok, what do you see in db for a user?

Screenshot 2022-02-13 at 21.03.09

These fields only

Strange, how can it get the eth address if the user uses the email for authentication?

It probably creates an address automatically. I can’t also seem to figure this out

it generates a key in the background using the email key :raised_hands: I believe @pushpit07

It’s very similar to Magic Link, but Magic link is quite centralized they store the key in the server

Web3Auth store user keys in their own p2p torus network (not sure if it is a blockchain or not)

So, I can’t access the email from Moralis dashboard?

That’s a bummer. @taha You guys should figure something out for this

I mean you can too, why not? but maybe you need to set the email manually after authenticating so it is also stored in Moralis DB, but yeah don’t think that should be a problem

Can’t seem to figure this out yet @cryptokid

Web3Auth provides a “Get User Info” method to get the user’s info. But I can’t seem to figure out how to run this through Moralis

1 Like

Hi @pushpit07
I have found out this snippet to get user info

You can try and let me know if its working meanwhile i am also using Torus to get user info, will share code snippet once ready

I’ve tried but this doesn’t work when using Web3Auth with Moralis

check this snippet using Torus module to get userinfo

Still not working. See this- How to get email when using Web3Auth?

How do I access the user’s email when they signup using Google? I want to know that. Is there any way to do so? Can you try doing that and let me know what you find?

did it help? I havent got the chance to try yet

let me know the status, will try again today