How can I fix the issue of my private PoA network on Geth returning 0 ETH balance for allocated accounts?

I’ve been trying to configure a private Proof of Authority (PoA) network using Geth on an EC2 instance. I have set up two nodes, but when I check the ETH balance of the accounts, it returns 0. Below is my configuration:

  "config": {
    "chainId": 123454321,
    "homesteadBlock": 0,
    "eip150Block": 0,
    "eip155Block": 0,
    "eip158Block": 0,
    "byzantiumBlock": 0,
    "constantinopleBlock": 0,
    "petersburgBlock": 0,
    "istanbulBlock": 0,
    "muirGlacierBlock": 0,
    "berlinBlock": 0,
    "londonBlock": 0,
    "arrowGlacierBlock": 0,
    "grayGlacierBlock": 0,
    "clique": {
      "period": 5,
      "epoch": 30000
  "difficulty": "1",
  "gasLimit": "800000000",
  "extradata": "0x00000000000000000000000000000000000000000000000000000000000000000405717696912fE792Db0d94C54F567a2d1e46CD0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
  "alloc": {
    "0405717696912fE792Db0d94C54F567a2d1e46CD": { "balance": "0x200000000000000000000000000000000000000000000000000000000000000" },
    "04e2f579f9B8B27B7B133F74860dB210cE4b8F63": { "balance": "0x200000000000000000000000000000000000000000000000000000000000000" }

  • Commands used:
  • Initialize Node1/2: geth --datadir node1 init genesis.json
  • Retrieve enode for bootnode: bootnode -nodekey boot.key -addr :30305
  • Start Node1/2: bootnode -nodekey boot.key -addr :30305
  • Check ETH balance:
  • Attach to Geth: geth attach node1/geth.ipc
  • Check balance: web3.fromWei(eth.getBalance(“0x0405717696912fE792Db0d94C54F567a2d1e46CD”), “ether”)
    I get a 0 ETH balance for the allocated accounts. I have tried multiple solutions but cannot figure out what is causing this error. Any help or suggestions would be greatly appreciated!
    Extra Notes:
  • I have created a separate account for each node.
  • I have checked: admin.peers on node1 and it has one peer connected.
  • eth.syncing returns false.
  • eth.blockNumber is undefined.

Hi @karim I would recommend posting this in your node support channel or on stack overflow.

Hello, if you may please clarify what is node support channel.

I mean the support service of the nodes which you are using.

I’m using Geth Node, Geth Private Network, I tried to look for a support channel by them but I didn’t find any, I will look again.