getTokenMetadata occasionally throws 141 error

recently I’ve encountered a problem, when some calls to the endpoints (e.g. getTokenMetadata, getTokenIdMetadata) did not work, even though normally they work without any problem. It returned me 141 error, probably similar problem as discussed here on the forum.

Moralis Server version: 0.0.282
Moralis SDK: 0.0.124
Chain: rinkeby
Server URL:
Application ID: R2KhTql2GqyNN3q8uVfMlV4sxt6sBt5tWIwwTDye
Log of some errors:

After this errors, I’ve bumped Moralis server version from 0.0.282 -> 0.0.283 and also updated Moralis SDK from 0.0.124 -> 0.0.128, which seemed to resolve this problem for a while and the getTokenIdMetadata endpoint did not throw error since, but the getTokenMetadata endpoint still occasionally throws the similar error to the one before:

Could you please check if there is not any problem on your side? Most of the time these calls works without any problems, but sometimes it throws this error. Thank you!:slight_smile:

1 Like

Hmm, unfortunately it seems that the getTokenIdMetadata endpoint has not been fully fixed either. Error message that I’ve got a minute ago (throwing for both getTokenMetadata and getTokenIdMetadata):

1 Like
x = await Moralis.Web3API.token.getTokenMetadata({"addresses":["0x5592EC0cfb4dbc12D3aB100b257153436a1f0FEa"],"chain":"rinkeby"});

works for me now, but it is not easy to replicate if there are intermittent errors

Is there any possibility to test this more on Moralis side? I am almost 100% sure that it is a problem on your side and it is still happening (as I can see in my Moralis Dashboard error logs). As I mentioned before, these Web3API calls fails only sometimes (but with the same data that works 90+% times).

This is app-breaking feature for us and we are planning to release our project in upcoming days, so are there any possibilities of having this investigated so it is fixed? Please let me know the options, if there are any.

You could try to update your Moralis server to latest version, but I don’t expect an improvement.

1 Like

Thanks, I’ve updated the server and it did not happen to me since. I’ll keep my eye on this and if the problem would still persist, I’ll post an update here:). Thank you so far!

It did not resolve this problem after upgrading it to 0.0.284, still same error happened occasionally.

After upgrading the server to 0.0.285 and SDK to the newest 0.0.131, it got even worse, as it started to throwing me errors “Invalid function: getTokenMetadata” and “Invalid function: getTokenIdMetadata”. Moreover it seems like now it throws this error all the time, not just sometimes as before.

My code for calling the getTokenMetadata endpoint:
await Moralis.Web3API.token.getTokenMetadata({ addresses: [contractAddress], chain: networkConstants.chainName })


My application and server url is above. Please could you have a look into this? We are planning to release our product soon (in next week) and this error makes our app practically unusable in most cases. Could you please prioritize?

1 Like

can you try another restart to your Moralis server?
I also updated a Moralis server to latest version, and I don’t get that error for a simple request.

I tested now with your server and it doesn’t work, with my server works fine, it looks like it is something strange with your server. You could try to restart it.

Thanks, after restart it works now, although I am still not sure if the initial issue with occasional errors has been resolved. I’ll let you know in case I’ll encounter this error again. Thanks for help so far, I appreciate it!:slight_smile:

Please the initial issue is still not resolved, getTokenMetadata and getTokenIdMetadata endpoints are still throwing occasionally errors on requests that most of the time passes without any errors. I’d say this is happening in about 5% cases and I was not able to reproduce the issue consistently, it seems random for me.

Even though it happens only about 5% times, this still makes this feature unusable for us. Could you please have a look into this once more? I can help you or provide any additional information that you need. Server URL and application ID is mentioned above in the initial problem descritiption.

I’m attaching logs from a few minutes ago:

Let me know! Thanks a ton:)

Do you happen to sometimes making more requests in parallel? Asking because there is another similar issue when making more than 10 requests in parallel that we also have to investigate.

Yes, that’s right, we make a lot of requests at once during the initial fetch. We are planning to change this behavior and save the data to our database (which should greatly reduce the amount of requests we need to make to getTokenMetadata and getTokenIdMetadata endpoints), but for now we are doing multiple requests at once (50+).

Ok, makes sense, it could be related to making requests in parallel. We will still have to investigate, but at least now we could assume that we know how to replicate the problem.

Yes, thanks! I’d like to point out that this problem does not occur all the time (even though we send similar amount of requests each time), so you might need to try multiple times to replicate this error:). Thank you very much:).

Hello, any updates please on this? Can I help you somehow? Thanks for info!:slight_smile:

It may work better now, did you see any errors in last hour?

Unfortunately yes, still the same issue:/.

Can you find a way to consistently replicate the problem?