getNFTs Web3 API error

Greetings! I have a problem. Please help.
When I trying to get users NFTs (getNFTs) it fails with error. Response is {"code":141,"error":"[object Object]"}
This error occurs on Mumbai network but method works fine on Rinkeby.

Server version: 0.0.259
JS lib version: 0.0.44

Thanks for attention!

Can you share your address? I tried with a random address and it looks like it doesn’t give an error for me.

Address is 0x2C0b0a4D8300AF35e2FDFE93D966B893BdB8005B

Hey @SergeiR

I’ve tested it with your address and it works correctly:


Could you check provided server_url and app_id?

I also tried another address 0xCc080c4eC62a1AeF1052fA55B4Ea39182f1ee345 but result is the same for me

Does not only this function work or others too?

You executed x = await Moralis.Web3API.account.getNFTs({address: "0x2C0b0a4D8300AF35e2FDFE93D966B893BdB8005B", chain: "mumbai"}) and it didn’t work for you?

I can connect and disconnect wallet. ATM I only tried getNFTs function of Web3 API.

Yes. Take a look please

I also can say that it was working fine before… Seems like there was an update (of the server) and it started to produce an error.
Perhaps for me it will be fixed by creating a new server. But if you would like to investigate this issue more I will leave it as it is right now.

Can you share your server_url and app_id?

Yes sure.
Server URL:
App ID: yCh3QlUbZuOyiJbKFyOYMR3DrzQOCBv9GCnBs96I

ok, I also have errors when using your server

Try to update the server, even if is the latest version.

Update: try to log into the admin panel, and then browse the web3 Api section:, if everything loads ok then the problem should be resolved

Just checked it. Yes, it working great now. Thank you! :+1: :muscle: :handshake:


I’m having this exact same problem.
In my case I’m using Ganache.

I can log in normally at

@Estvb, with local Ganache web3api doesn’t work, that is why you may get that error

1 Like

Now it makes sense.
I believe that may be why I am not able to use the API either.

Is this information somewhere in the documentation? I did not find it.


It may not be in the documentation, what you mean by I am not able to use the API either?