Get NFTs call don't see all minted NFTs

I am testing out NFTs contracts on Rinkeby network.
Created couple of contracts with the same names and some different ones.

I go to the dApp and call mint with some test metamask wallet
When I ask moralis getNfts - in response only SYNCED and some old NFTs.

There are no new minted nfts appearing in getNfts response.
Is there some cooldown for loading new contracts to your servers to be synced?
It already 1 day passed and there are still no newly created NFTs on my wallet address.

When calling contract - it says that my wallet possesses NFT already.

But why Moralis SDK canโ€™t see them while calling getNFTs?

I even tested getTokenMetas and getTokenIdMetadata - it says no metadata found.
Also I tried to use couple of times resyncMeta and tokenUri - no response

Though I deployed about 5 of them to the Rinkeby. The first two are working, but the others - Moralis just donโ€™t see them. Or donโ€™t see them yet?

Is there a cooldown for updating NFTs balance for particular wallet?
Or how long does it take?

I am guessing the nfts are seeing are fairly old, because rinkeby is no longer supported by Moralis

1 Like

Too bad, but I can understand that.

I didnโ€™t read news about that.
Thanks for the information

The Rinkeby removal is covered here.

you can try to access a token id directly with getTokenIdMetadata, it will try to sync automatically the entire contract after that if it was never synced