Generate NFTs with this simple code (this could make you millions) PART 1

I’m new to programming and got up to 11:17 in the video (the part where you type node index.js and I keep running into a parse error with code 100. What should I seek out to rectify the issue. Thanks so much for your support.

1 Like

Did you look at the code from Github: ?

Can you give more info about the error that you get?

Yes, the code I am using is cloned from the link you provided.
This is the result:

[email protected] moralis-mutants-nft-engine-main % node index.js

Generative Art

- Generating your NFT collection


Mutating 1 of 10

  • rarity: original
    use random rarity original
  • dna: 00-00-00-01-01-02-00-01-00
    error = new _ParseError.default(_ParseError.default.CONNECTION_FAILED, XMLHttpRequest failed: ${JSON.stringify(message)});

ParseError: XMLHttpRequest failed: “Unable to connect to the Parse API”
at handleError (/Users/nicolaharvey/Documents/CRYPTOCURRENCY/BANTERPUNKS/CODE-GENERATING-TEMPLATE/moralis-mutants-nft-engine-main/node_modules/moralis/lib/node/RESTController.js:440:15)
at processTicksAndRejections (node:internal/process/task_queues:96:5)
at async saveFileIPFS (/Users/nicolaharvey/Documents/CRYPTOCURRENCY/BANTERPUNKS/CODE-GENERATING-TEMPLATE/moralis-mutants-nft-engine-main/index.js:264:24)
at async handleFinal (/Users/nicolaharvey/Documents/CRYPTOCURRENCY/BANTERPUNKS/CODE-GENERATING-TEMPLATE/moralis-mutants-nft-engine-main/index.js:333:21)
at async startCreating (/Users/nicolaharvey/Documents/CRYPTOCURRENCY/BANTERPUNKS/CODE-GENERATING-TEMPLATE/moralis-mutants-nft-engine-main/index.js:337:5) {
code: 100
[email protected] moralis-mutants-nft-engine-main %

it looks like you will need to modify some lines in index.js:

Hello, I am getting sticj at this point as well only I cant do the NMP install:

[email protected] moralis-mutants-nft-engine-main % npm install
zsh: command not found: npm
[email protected] moralis-mutants-nft-engine-main %

Any help is greatly appreciated

it looks like you need to install node first on your system

Thank you for the reply but I do have it installed
from terminal:
Welcome to Node.js v16.13.1.

Same terminal from where you try to execute npm?

same difference on the other terminal
Welcome to Node.js v16.13.1.

Maybe you need to change from zsh to something else

added permissions, tried installing homebrew…sigh…no luck

Perms check on local node_modules not ok Check the permissions of files in /Users//Desktop/moralis-mutants-nft-engine-main/node_modules (should be owned by current user)
Perms check on global node_modules ok
Perms check on local bin folder not ok Check the permissions of files in /Users//

It looks like a path problem, not permissions
Do you know how to choose a different shell for terminal instead of zsh?

yes tried bas and a couple other

Can you try to reinstall mode?

reinstalled same error

How did you install it?

ran the installer from node.js

Can you install it from terminal from command line?

just did it same error. I tap out. Thanks for trying.

Did you restart the terminal after installing?