Generate NFTs with this simple code PART 2 - Issue w/ Listing on OpenSea Testnet

Hello, First time posting, happy to be here. Going through this Youtube tutorial trying to launch our first NFT collection, and made it all the way to the end of part 2, where we deploy the smart contract onto the Testnet and then go get listed on OpenSea. All of the graphics did generate correctly and can access them in IPFS (following the URL listed in my Moralis server.)

But for some reason on OpenSea it seems only about half of the collection is showing correctly with the graphic, but the rest are blank. This is the second time running this code and same thing happened before, that is some of the NFTs images are not showing up properly in the OpenSea listings. It’s been over 36 hours since deployment.

Has this happened to anyone else? Or any ideas why some of the NFTs are not showing properly on OpenSea and how to fix?

Thanks in advance!

Here’s the link to the collection on OpenSea Here

Collection screenshot:

Did you check if the metadata uri / ipfs image url is loading for those images?

Yes, the metadata uri and ipfs image url did get generated correctly and DO load properly for those images (which don’t appear in OpenSea listing.)

Here’s an example for image #10, metadata

Here’s the #10 image

So why does this NFT appear blank incorrectly in the OpenSea listing? (while others in the same collection do appear correctly)

Can you share the metadata for one of the working ones? Looking at your broken tokens, it doesn’t seem to be pulling any metadata at all like image or description.

If all the paths are correct and accessible, maybe you can try to force update metadata with the below path.

In the below path replace ContractAddress and NftID with your NFT details.

Here is the metadata for side by side comparison, between a good one vs a broken one (on Testnet).

#9 This one is good (shows properly on OpenSea listing):
{“dna”:“01003013013901309”,“name”:"#9",“description”:“Tulip Maniacs”,“image”:“",“edition”:9,“date”:1651433073453,“attributes”:[{“name”:“Tulip_3-1_0005s_0002_Red-Background”,“rarity”:“original”},{“name”:“Tulip_3-1_0002s_0002_Stem-Medium”,“rarity”:“original”},{“name”:“Tulip_3-1_0004s_0002_Pink-Base”,“rarity”:“original”},{“name”:“Tulip_3-1_0003s_0011s_0006_Big-Dots-Blood-Orange”,“rarity”:“original”},{“name”:“Tulip_3-1_0001s_0012_Drool”,“rarity”:“original”},{“name”:“Tulip_3-1_0000s_0003_Teary-Eyed”,“rarity”:"original”}]}

#10 This one is broken (shows blank on OpenSea listing):
{“dna”:“0120302007901401”,“name”:"#10",“description”:“Tulip Maniacs”,“image”:“",“edition”:10,“date”:1651433073453,“attributes”:[{“name”:“Tulip_3-1_0005s_0004_Yellow-Background”,“rarity”:“original”},{“name”:“Tulip_3-1_0002s_0002_Stem-Medium”,“rarity”:“original”},{“name”:“Tulip_3-1_0004s_0012_Indigo-Base”,“rarity”:“original”},{“name”:“Tulip_3-1_0003s_0002s_0014_Thin-Rim-Black”,“rarity”:“original”},{“name”:“Tulip_3-1_0001s_0014_Awe”,“rarity”:“original”},{“name”:“Tulip_3-1_0000s_0009_Monocle”,“rarity”:"original”}]}

IMO the metadata and image URL seem correct for both, but for some reason #10 doesn’t show up on OpenSea listing (testnet). These were all generated using the same code at the same time, no difference.

I’d appreciate any suggestions on how to fix this. thanks

thanks for the suggestion to force metadata update. I tried this for #10 (broken one) but got an error, can you suggest what I may be doing wrong? thanks

below, I’ve replaced the contractAddress and NftID:

This is what returns from the link above:

Yes that’s very odd. Seems #10 has synced up properly as token ID 16, but the original hasn’t been deleted.

So this same issue has happened on multiple deploys with the same code? How many NFTs should there be in the collection if it was all working?

I tried your testnet API call, I get the same issue and all the syntax looks correct. The issue with that is, even if you had to use it and it worked, there doesn’t seem to be an option for it on mainnet.