./frpc -c frpc.ini Error: connection refused

Can someone help me understand why I’m getting the following error when running

./frpc -c frpc.ini
./frpc -c frpc.ini
2021/05/09 15:26:40 [W] [service.go:104] login to server failed: dial tcp x.x.x.x:7000: connect: connection refused
dial tcp x.x.x.x:7000: connect: connection refused

I believe I’ve configured the frpc.ini file correctly. Just copy and paste from the Devchain Proxy Server… And yes I’m running the command from the same directory as frpc.ini

I’m really not sure what I’m doing wrong. I’ve had this working before but now when I spin up a new server it doesn’t seem to connect and it no longer connects to the original server when I revert the frpc.ini file. Any thoughts?

You did copy the red colored “ganache” part into the frpc.ini file (with nothing more), like:

[common]
  server_addr = 03uqj0cfwji7.moralis.io
  server_port = 7000
  token = yxwa6QkSpx
[ganache]
  type = http
  local_port = 7545
  custom_domains = 03uqj0cfwji7.moralis.io

Did you start the instance like (windows version):

./frpc.exe -c ./frpc.ini

with ganache running

and Metamax -> Settings -> network as:

??

Here is my frpc.ini file. This was cut and pasted straight from the moralis server.

[common]
  server_addr = 0yhenbrmchz3.moralis.io
  server_port = 7000
  token = Lr9pHgQ2fH
[ganache]
  type = http
  local_port = 7545
  custom_domains = 0yhenbrmchz3.moralis.io

I am on a mac so to run it I use the following command from the same directory as the frpc.ini file:

./frpc -c frpc.ini

Perviously I did not have metamask connected. However, I do now and it is accurately reflecting the balance shown in my Ganache instance so I know it’s connected correctly.

I still have the error connection refused…I’m really not sure what I could be doing wrong…