Firebase doesn't create realtimedatabase entry on moralis auth

Hey guys, a while back i made my firebase application with moralis auth and all worked smoothly because I think my firebase realtime database rules were very loose, basically everyone could write etc. Now this has changed (auto changes after x time) i decided to test with proper auth rules in there. And now no longer a realtime database entry is created whenever i login with metamask.

I tried to do this with a new metamask wallet and it seems the auth seems to go well because on the authentication tab in firebase I see the login happening, but no entry is happening in the realtime database.

Does someone have experience with this and know if it is my rules or perhaps something related to the auth extension?
Rules tab looks like the following:

  "rules": {
    ".read": "true",
    "users": {
      "$uid": {
        ".write": "!data.exists() || $uid === auth.uid"

Thank you!

It doesnโ€™t seem to be related to the realtime database as if i set all permissions to true the same thing happens.

I have made no changes to my code since last using it but seems to be no longer creating users on auth. Did something change in the firebase extensions or should i perhaps update or something?

It also seems the users are created inside my moralis dashboard just fine. Theyโ€™re just not written into the realtime database of firebase.

Hi, you can try to update to the latest version

firebase ext:update moralis/moralis-auth