Facing an Issue related to Favicon of Website

I added a link to our website in Moralis unity SDK (walletConnect) when I scan a code through metamask wallet,
my icon show clipped from borders.
I asked the website guy to change the favicon icon, and now he changed and updated it.
Still, when I scan the code, it shows me the old favicon.
note: Updated in browser but not updated when i scan.

maybe is some caching issue somewhere, wait some time to see if it gets fixed

looks like chache issue, but where can I refresh chache of Moralis.
chache from server is ok
refreshed and working fine on Browser

where is that icon saved? still not working now?

icon is saved on our server, link is live.
refreshed on browser it changed but when I scan through metamast it still not changed.

note : I use two different phones and two different metamask App. (still issue)

I don’t think that is an issue on moralis side, maybe metamask has a cache for that icon?

but i used two different mobiles and two different Apps.

can i share you the website.

here is the link : can you check it.


that is an app? I don’t know what to expect

this is a website, which have issue in favicon.
favicon in browser is different.
and favicon in metamask is different


It seems like something related only to Metamask, not to moralis.

but we set Favicon according to that standard

maybe it is a cache on metamask side. when did you change it? how long ago?

changed about 4 hours ago still issue

maybe you need to wait 1 day, I don’t know

did you try from a different browser too? like one that doesn’t have some cache from before

yes i tried different browsers, in which i changed favicon later

Can you post a screenshot of the icon being clipped on your end? In MetaMask your favicon looks fine if I connect the oengoo.com website manually.

check difference between upper and lower icon.
upper icon is icon link , lower icon is from website favicon.