_EventSyncStatus table shows 2 events synced but no data

I set up an event sync and I can see the record of this event sync in the _EventSyncStatus table, and it even lists that 2 events have been synced. However, the table that the event data is supposed to be in has zero records in it. Tried deleting and re-adding, same result.

Whenever I try and make a new event sync for a different event, the ERC721 “Transfer” event, it works without a problem. But using any custom events that I have added in my contract don’t seem to work.


Try restarting your server.

@glad Tried that, didn’t work.

Can you post your contract address, chain and ABI? Will try on my end.

you have to remove that _ from the name fields, it will not work if the name starts with _

you can also post the server url if you still have problems

1 Like

@cryptokid That did the trick – simply removing the preceding _ from the field names in the ABI, didn’t even have to update it in the actual contract.

Any idea why that is out of curiosity?

It is related to how we process data internally.

1 Like