Event sync not showing event data in database - OpenSea Clone

Hi, I’ve setup a sync event that watches for an item to be created.
The event is occurring but the data is not being displayed in the database.

Did you enable the option for syncing historical events? What were your sync settings that you used? You may have to create it again and sometimes you have to restart the server.

It can also depend on what abi was used. If the names in the abi have _ then it is not going to work.

Hi glad how’s your morning going? To answer your questions, I tried the first time without historical, the next couple times I did it with historical because I wanted to see some previous transactions. I tried with historical at 500 and with limited to 50, my wallet is new however so there is only about 10 transactions in total. I have previously tried to restart the server on the new UI as well as the legacy UI.

Good morning as well cryptokid, how are you?
I’m using the section of the abi that was used in the video. It’s just the event that I’ll be trying to watch.
I’ve attached some photos showing the sync setup and the abi, the second image just shows the scroll down so you can see the rest of the abi.

That address of 0xd9145CCE52D386f254917e481eB44e9943F39138 that you’ve used doesn’t seem to be correct, it shows as USDC on mumbai.polygonscan.com. Could you paste it here in case I made a typing mistake from your screenshot.

Okay, this is it copy and pasted from the sync event:

This is that contract address on polygonscan. You need to use your marketplace contract address.

Sorry I thought this was the right one, I should mention I’m working on a the mumbai testnet for this tutorial.
This is the screen that I get on polyscan showing the create Market Items. Is this wrong?

For the tutorial, it’s meant to be this contract. Did you deploy your own?

Yeah I copied that contract into remix and deployed it to get the address of the contract.

The contract address you have given is a different contract - you can view the source code.

I’m not sure what’s causing that. I copy and pasted the code from the github into a the .sol file again in remix and re-deployed, the address is now: 0xd8b934580fcE35a11B58C6D73aDeE468a2833fa8
But this is showing the same source code as the last one. Deployed

You need to select which contract you want to deploy in Remix (make sure it’s compiled first) on the “DEPLOY & RUN TRANSACTIONS” page under “CONTRACT”. Please make sure you’re following through the tutorial, it should cover this step.

Also those contract addresses you are posting are coming from somewhere else anyway, because both contracts are many months old.

Here’s a screenshot of the deployment and the settings I used.

With the contract I think when I set it up I created a .sol file and copy and pasted the contents of his into it. So that could be why the dates don’t match up. In the tutorial video he kind of introduces remix and the contract but he doesn’t go through deploying the document.

The current address is this again: 0xd9145CCE52D386f254917e481eB44e9943F39138

For learning Remix, you can read this and try it out.

So I figured out the environment was not on the “Injector Provider - Metamask”.
I now have the contract connected and deployed with metamask.
When I list an item however I get this error

This is the new contract address: 0xd5273EB8c8F91a45971b95b26Eb96C7988C9c1d3

Make sure your wallet is on the right chain (Mumbai). You can paste the transaction hash here.