Error when using 1inch Dex in ethereum-boilerplate

I have set up the ethereum-boilerplate and I have tried to make swaps but keep getting this error. The live Dex is at https://monkeyninja.io if you would like to try for yourself.

And sometimes this is the error:

Any help appreciated!

You don’t have enough native tokens to make the swap.
Make sure to have enough tokens + some extra to pay tx fees.

Thanks @dani

What about the first error I posted? Does it mean the same thing? If so, is there a way to edit these messages to be easier for a user to understand?

Thanks!