Error: Command Failed: ... Permission Denied (SOLVED)

Trying to connect my ganache server, but getting these errors leaving me with no idea how to fix them. I’m on Mac. Also, I didn’t change the name of the folder when downloading off of GitHub, so apologies for the ugly text.

When I try to run the ./frpc -c frpc.ini command, even after opening both my frpc and frps files with control + click, I receive this:

[email protected] moralis % ./frp_0.37.1_darwin_amd64 -c frpc.ini
zsh: permission denied: ./frp_0.37.1_darwin_amd64

When I try to connect with the connect-local-devchain command, I get all the way to selecting which server I want to connect to, and after selecting Ganache, I get hit with this error:

exec error: Error: Command failed: “/Users/devin/moralis/frp_0.37.1_darwin_amd64/frpc.ini” http -s elvp5kzkxlkh.moralisweb3.com:7000 -t XSlSHZvTd4 -l 7545 -d elvp5kzkxlkh.moralisweb3.com
/bin/sh: /Users/devin/moralis/frp_0.37.1_darwin_amd64/frpc.ini: Permission denied

Received this while following the CLI tutorials, and it didn’t seem as though anyone in the comments had this issue. Thanks for taking a look, I appreciate the help.

Hi,
What do you see if you run ls -al in your frp directory?
It should show you what access rights you have for the files found in that directory.

Thank you for the reply, here is what I see when I run ls -al:

[email protected] frp_0.37.1_darwin_amd64 % ls -al
total 51608
[email protected] 11 devin staff 352 Aug 30 00:40 .
drwxr-xr-x 9 devin staff 288 Aug 30 00:34 …
-rw-r–[email protected] 1 devin staff 6148 Aug 30 00:50 .DS_Store
-rw-r–[email protected] 1 devin staff 11358 Aug 3 11:25 LICENSE
[email protected] 1 devin staff 11298720 Aug 3 11:20 frpc
-rw-r–[email protected] 1 devin staff 126 Aug 3 11:25 frpc.ini
-rw-r–[email protected] 1 devin staff 9503 Aug 3 11:25 frpc_full.ini
[email protected] 1 devin staff 15070208 Aug 3 11:20 frps
-rw-r–[email protected] 1 devin staff 26 Aug 3 11:25 frps.ini
-rw-r–[email protected] 1 devin staff 5010 Aug 3 11:25 frps_full.ini
[email protected] 6 devin staff 192 Aug 3 11:25 systemd

Access rights look ok.
The executable file that you have to execute is frpc, your command should be something like ./frpc -c frpc.ini and you should put your server url in that frpc.ini file.

Thank you for the assistance! Your reply helped me in noticing that I had entered the wrong paths for the ./frpc -c frpc.ini command. My Devchain Proxy Server status is now at connected! I had a similar confusion with the connect-local-devchain command and have fixed that as well.

3 Likes