EIP 1599 Issue Metamask

Hi There! Do you have any idea what is going on here,

" MetaMask - RPC Error: Invalid transaction params: params specify an EIP-1559 transaction but the current network does not support EIP-1559 {code: -32602, message: “Invalid transaction params: params specify an EIP-…but the current network does not support EIP-1559 "}

This is the way I called

  const WETH9 = new web3.eth.Contract(abiWETH9, contractAddressERC20);
  WETH9.methods.approve(marketContract, amount).send({from: walletAddress})

The above code is working on some of Metamasks, Is this something related to Metamask?.

it looks like updating metamask may fix the problem

1 Like

@cryptokid It works, Thanks

@neil @cryptokid Im getting the same error when trying to approve my transaction using metamask where my network is mumbai with rpc moralis speedy node url. Looks like Metamask is updated yesterday and now it’s giving that issue, if updated metamask to latest version 10.8.0, still getting same error? @neil How did it fix for you after update? Did you do anything different for metamask?

@cryptokid The link you mentioned, that issue is still open :frowning: It did not fix for some people.

Please let me know. Waiting for your reply.

@cryptokid have the exact same issue on the mumbai network with my app. Update for metamask is not available on firefox yet.

it looks like downgrading metamask to 10.1 worked for someone for Mumbai network

1 Like

@cryptokid Yes, it worked after downgrading as well as for latest version now, not sure if metamask team upgraded their app in the background, but now its working fine. Thanks.

I’m having the same problem on Chrome. Which version of Metamask exactly is supposed to work? I’m using 10.8.0, which is the latest.

How we fixed our side so far is as below.

  • backup accounts
  • remove Metamask
  • reinstall Metamask
  • add accounts
1 Like