Display App name on the signing message popup metamask

I am authenticating the user of my Dapp (android/IOS) to metamask wallet (android/IOS). It is working smoothly. The issue is that it shows the variable “L” as heading instead of my app name. How can I replace the “L” with my appname and this localhost heading? Please guide me as I didn’t find anything related to this on the forum
Image is attached

that L seems to be from localhost, it may be simply from the current site

How can I replace that localhost to my app name, I have changed the app name inside my android manifest file and config.xml but still its showing localhost?

I don’t know that. I thought that it depends from where the app is accessed.

Can’t we use any attribute inside the moralis authenticate function for this purpose? @cryptokid

I don’t think that it is related to authentication. From that print screen it looks like it is even before authentication. From when the wallet is connected.

this is from enable web3… @cryptokid

It looks like it is from when you connect the wallet in first place. You could connect the wallet to a website directly form the wallet application too, at least with MetaMask extension in the browser.

My app is android/ios based so I only want to use the mobile metamask wallet @cryptokid

I don’t know then. You say that you are using wallet connect?

yes, I am using wallet connect

Maybe you will have some localhost reference in you mobile application.

It is a website with wallet connect or a native application?

a native application…

there are options in Moralis.enableWeb3 but they dont work i.e. displayName and appLogo in the enableweb3 options

Did you try both on iOS and android?

You can also try to use walletconnect directly if it works better for you.

yes, i have tried both on android and ios

try to search if there is any string with localhost in your code then

I have also done this and there is no localhost string inside my project