Defi Wallet not working with Moralis and WalletConnect

Hi. CDC ( Defi Wallet is not working with Moralis and WalletConnect. When connecting with authenticate with the Moralis JS SDK, the modal does not show up (with chain id 25). This is fixed by changing the MoralisRpcs.js file to include 25: ''. The problem is that as soon as I execute the signing transaction I get this error.

isAuthenticated, isWeb3Enabled, isWeb3EnableLoading are all true, but when executing a transaction I get that error. How is this possible when those 3 variables are true?

The Chronos hackathon is coming next month and the CDC Wallet (the most used wallet for Chronos) is not working for Moralis. I’ve tried many things to make this work and nothing seems to do the trick. This is vital for our product so I’d appreciate the help. :slight_smile:

Does this happen with other chains?

Nope :frowning: I’ve tried with Ethereum and it doesn’t happen.

Does this error happen when you actually sign/confirm the transaction or when you run the transaction code (e.g. with executeFunction)?

Can we see your code? Maybe try running another manual await enableWeb3({ provider: 'walletconnect', chainId: 25 }) before running your transaction.

Yes, it happens when using executeFunction, not when actualy signing the transaction. I’ll try using enableWeb3 and get back to you.