Data: 'Invalid apiKey / apiSecret'

Hey Devs Since yesterday I have been stuck on this problem and it still continues to bother me

i want to deploy react dapp based on ethereum-boilerplate template
API key and Secret key I placed in the .ENV file

my folder path is directed to build folder
when i run moralis-admin cli deploy
i only get one option to specify the API secret no option to specify API key

at the end of the result I get that error


what happens if you remove from env file api key and api secret?

even removing the SecretAPI && API Key from env file does not give me any option other than the option to specify the secretAPI Key

when I hit enter/run it returns the same error

something seems strange, can you reinstall moralis-admin-cli, or install it in a separate local folder?

Sorry What Do You Mean install it install in a separate locali folder ? it means to install it in etehereum-boilerplate folder??

You can install it globally, or in a separate folder where you have a project for example

I tried it still i get same result can you try to deploy react app and see thir options

also i followed this totarial from moralis
for me there is no option to set API KEY etc

you can create a new folder
in that folder you execute npm init --yes
then you execute npm install --save moralis-admin-cli

and it will install moralis-admin-cli in a new empty project in that folder, than you can run moralis-admin-cli from that folder

then this new folder is outside of Build folder how can i access Build folder considering
Destination folder must contain: index.html!,
or in the new folder then I paste all react files?
if possible please show me Folders / files structure I will be more grateful
even in the sandbox

If you want to specify another folder, you can do that by using the --folderPath or -p flags.
moralis-admin-cli deploy -p C:\myDapp\

i have tried this and totarial imitation still get the same error

the solution I tried

1-Update / restart server
2- installing moralis admin cli in separate file

I still don’t get a option to specify the moralis API KEY only Moralis Secret key

Unexpected error
Error: Request failed with status code 403

can you delete that env file that you are using, or rename it to something else? maybe it is still reading from it