Cursor pagination doesn't work

Cursor based pagination doesn’t work for the transactions web3 API endpoint. An example request:

The total returned by this request is 109, so we need to query several pages. When running the same request with the cursor returned in the response, I’m getting absolutely the same response, except two fields: page and cursor. And this happens infinitely.

To reproduce: try to get all 109 transactions with provided parameters.

we will investigate, thanks for reporting

1 Like

I am running into the same thing when querying an 1155 (0x7EeF591A6CC0403b9652E98E88476fe1bF31dDeb) with 4953 results using 99 as the page size (I also tried 90). When I decoded the cursor JWT, one of the keys started repeating and the tailOffset is always 99 (or 90) even though the page keeps going up.

Which specific endpoint method are you using?

I’m using the API: Moralis.Web3API.token.getNFTOwners

I’m not able to replicate this - the results seem to be different for each page (tested from 1 to 5 with a limit of 99). Do you mind sharing the response data (e.g. screenshots) where the results are duplicating?

It doesn’t start replicating until page 29 or so depending on the page size.

I’ll try to get a run with output.

I will take a look to see if it replicates

it replicates for 90 page size

It’s been a month and you still haven’t fixed the issue? I’m trying the same request from the issue title and it still doesn’t work. Any time estimates on when the solution comes?

1 Like

@mdnatx, that issue is fixed now

@mpoplavkov, I’ll get with new updates today on that case

1 Like

Thanks! I was able to confirm I could get all the pages.

1 Like

@mpoplavkov, it should be fixed now