Cloud code not saving

When I save my cloud code, the changes are not reflected and the server runs on the previously saved code. In addition to this, i cannot update/restart my server as I get this message:

There is a Cloud Function Error (Syntax/Undefined Variables) on your code, in order to Update/Restart your server fix the error first, You can check the full Log on the Dashboard -> Logs -> Error

Even when I use the moralis-admin-cli to try and update my server (called CrazyBlock), the server does not show up as one of the options that I can update. Does anyone have any insight into this and how to fix it?

Hi @gadgetman6

Please provide your server subdomain (Check this)

1 Like

there are two possible cases:

  1. because of seamless cloud code updates:
    while the cloud code updates on all the CPU cores then you will see that error and you will not be able to restart the server, you can wait 10 minutes in that case

  2. sometimes you get that cloud code error even after 10 minutes after you update the cloud code (when cloud code doesn’t really have an error), in that case you can not easily restart the server yourself now

1 Like

Subdomain: fvzemaecj5mt

fixed, you should be able to restart the server now

1 Like

Yomoo, the initial server update/restart worked, and I was able to sync my cloud code again. However, this only lasted until I got an error in the cloud code. After fixing this error, my new changes are once again not being reflected in the cloud code sync and I am once again not able to update/restart my server due to the same error I was having before.

cryptokid, how do I enable seamless updates in my server?

they are enabled by default from what I know

Could you restart my server again?

Can you restart my server again

the server is restarting now