Can't find solution to error

Hi! I’m following the NFT minter programming tutorial but I have two small issues.

  1. When I try to put my Hash into my search bar (with ipfs://) I just get the usual search results from Google.
  2. When I try to test the first NFT, I get a very long error. I will send a picture right after.
    I’d really appreciate it if you could help me with this problem. Thank you!

The error is telling your that a required parameter (userAddress) is missing from your payload.
Check the docs and try again:

1 Like

Thank you! I managed to fix it, the error was due to a missing letter :l

However I have another error now, yay.
Do you know what is wrong?

this one seems more complicated, seems to be related to what chain ID is selected in metamask, 1 is eth mainnet and 4 is rinkeby

That’s what I was thinking… I have no clue on how to fix this. I’m open to suggestions

try to change the network in metamask

I found how to change the network, including the chain id. What should I change it to though? When I put 1 it says “This Chain ID is currently used by the mainnet network.” and when I put 4 it says “This Chain ID is currently used by the rinkeby network.”.

Also, what should I put for the Network Name and New RPC URL?

not sure what you mean, don’t you already have those chains in metamask?

you can try with speedy nodes:

You said I should change the network so I’m just wondering what I details should I put. I’ll attach a screenshot.

I tried changing the network to rinkeby with a chain id of 4, and it worked! Thank you so much for helping me!