Build Your Own DAO - Helping Each Other

Lets use this thread to support each other with questions regarding the Build Your Own DAO Project :star_struck:

Read instructions: https://www.youtube.com/watch?v=sAcEJcwPTOk

Feel free to ask for help here - but also ensure YOU HELP people that are asking questions you know the answers to

The Moralis staff and community managers will be keeping an eye on this too :star_struck:

4 Likes

I get the error: execution reverted: This Proposal does not exist
Is there someone who knows what can trigger this error?
Thanks for the video and all the knowledge!

Kind regards wokkel.

How does that error happen exactly?

You can compare your code with the final repo: youtube-tutorials/DAO-Final

1 Like

Hi there,

Iam trying to deploy the contract but i received this error:

HardhatError: HH110: Invalid JSON-RPC response received: {“error”:“unauthorized”}
at parseJsonResponse

Can you share hardhat config file? Any idea?

Try using another RPC URL for the chain you’re using (you can search “chainhere rpc” for public ones).

And check your private key in your hardhat config is correct.

1 Like

@glad thanks so much for helping me and others.
Finally almost everything works. I created my own smart contract and abi and verified it.
The contract interactions are working accordingly. I have deployed the front-end code and I have created my custom css code to change the feel and look. However when I deploy the code the custom css is working in my local server. But it is not working online. I have tried to upload it via npm build run and also via vercel and git code. Can someone pleas explain why my custom code is not working on the web? I dont have friends or contacts who can help me out… Thanks moralis for all the video’s and content and information. What you all are doing is a starting a new revolution to decentralize the web. I am just starting to develop so have a long way to go. If someone has the answer on my question that would be great. Thanks community and moralis.

So it works fine when built (npm run build) and run locally (using a local server) but not when deployed?

Do you get any errors in your deploy logs?

1 Like

It runs fine in local server. But when i use npm run build it does not work.

It runs fine in local server

Do you mean serving your build folder after a successful npm run build?

Can you post any errors you are getting. Or you can share your project on GitHub.

When I deploy my react app in my local server:3000. I see that the css code is working for the website.
When I do npm run build and put the build folder in netifly and set it online. I dont see my css changes that i put into src/pages/pages.css.

Windows PowerShell
Copyright © Microsoft Corporation. All rights reserved.

Try the new cross-platform PowerShell https://aka.ms/pscore6

PS C:\Users\Superwokkel\Documents\GitHub\DAO-DAPP> npm run build

[email protected] build
react-scripts build

Creating an optimized production build…
Compiled with warnings.

./node_modules/moralis/lib/browser/Web3Connector/MagicWeb3Connector.js
Module not found: Can’t resolve ‘magic-sdk’ in ‘C:\Users\Superwokkel\Documents\GitHub\DAO-DAPP\node_modules\moralis\lib\browser\Web3Connector’

src\pages\Home.js
Line 151:6: React Hook useEffect has missing dependencies: ‘Moralis.Object’, ‘Moralis.Query’, ‘Web3Api.token’, and ‘getStatus’. Either include them or remove the dependency array react-hooks/exhaustive-deps

src\pages\Proposal.js
Line 65:6: React Hook useEffect has missing dependencies: ‘Moralis.Object’, ‘Moralis.Query’, and ‘proposalDetails.id’. Either include them or remove the dependency array react-hooks/exhaustive-deps

Search for the keywords to learn more about each warning.
To ignore, add // eslint-disable-next-line to the line before.

File sizes after gzip:

933.18 KB build\static\js\7.a98fef5a.chunk.js
305.69 KB build\static\js\4.3fc3b7cf.chunk.js
94.22 KB build\static\js\8.ec56c165.chunk.js
73.75 KB build\static\js\3.019744e4.chunk.js
61.14 KB build\static\js\1.47d8f8e7.chunk.js
17.74 KB build\static\js\0.8704d58d.chunk.js
11.24 KB build\static\js\9.e12ed5d8.chunk.js
10.47 KB build\static\js\2.6bcda5cc.chunk.js
3.37 KB build\static\js\main.38abd1ba.chunk.js
2.49 KB build\static\js\12.c35938a0.chunk.js
2.38 KB build\static\js\17.6ec541b2.chunk.js
2.11 KB build\static\js\10.f1808903.chunk.js
1.74 KB build\static\js\18.433c5de7.chunk.js
1.53 KB build\static\js\16.720f9c34.chunk.js
1.32 KB build\static\js\runtime-main.751215b2.js
1.1 KB build\static\css\main.f9b5e605.chunk.css
452 B build\static\js\14.8057f8e4.chunk.js
163 B build\static\js\11.06fa26b5.chunk.js
154 B build\static\js\13.0e2a9643.chunk.js
151 B build\static\js\15.db419c22.chunk.js

The project was built assuming it is hosted at /.
You can control this with the homepage field in your package.json.

The build folder is ready to be deployed.
You may serve it with a static server:

serve -s build

Find out more about deployment here:

https://cra.link/deployment

PS C:\Users\Superwokkel\Documents\GitHub\DAO-DAPP>

Can you share a repo of your project.

Thanks for helping appreciate it!

Are you referring to the slight colour changes? Those are the only differences I’m seeing between running it in development and when built/deployed.

Also on a side note, next time don’t upload the node_modules folder when sharing your projects.

I did not know that, won’t happen again. Yeah why is the color change for example not visible in build if I may ask?

It’s an issue with how you’ve tried to apply custom styles to the web3uikit components using the generated class names. It would only work locally; when deployed, new class names will be generated.

For example, you have this for changing the textbox colour on the Proposal tab:

.eswRrH {
  border: 1px solid #ecb663 !important;
}

One way to do it is in Home.js, add an id of form:

<Form id="form"

And then in pages.css, replace it with:

// use browser inspect to find out what you can target
#form > .form-item > div {
  border: 1px solid #ecb663;
}

And then do the same for all of the other unique class names you’re using. If the component is using a regular class or ID name you can try using that directly instead. But you can’t be using ones like exaJAs.

1 Like

How can I change the color of the ongoing text?

I have tried everything tho I still dont understand how to target the code…

sorry have to learn a lot.

      <Table

        style={{ width: "60%" }}

        columnsConfig="90% 10%"

        data={votes}

        header={[<span>Address</span>, <span>Vote</span>]}

        pageSize={5}

      />

      <Form id="text-Ongoing"

        isDisabled={proposalDetails.text !== "Ongoing"}

        style={{

          width: "35%",

          height: "250px",

          border: "1px solid rgba(236, 182, 99, 0.2)",

        }}

        buttonConfig={{

          isLoading: sub,

          loadingText: "Casting Vote",

          text: "Vote",

          theme: "secondary",

        }}

        data={[

          {

            inputWidth: "100%",

            name: "Cast Vote",

            options: ["Accept", "Reject"],

            type: "radios",

            validation: {

              required: true,

            },

          },

        ]}

        onSubmit={(e) => {

          if (e.data[0].inputResult[0] === "Accept") {

            castVote(true);

          } else {

            castVote(false);

          }

          setSub(true);

        }}

        title="Vote on proposal"

      />

    </div>

  </div>

  <div className="voting"></div>

</>

);

I also added color code under ongoing. That was also not working…

You typically use the color property. You may need to select text-Ongoing textarea (or whatever element you’re referring to):

#text-Ongoing textarea {
  color: blue;
}

If you use your browser inspect, you can add styles directly, etc. This way you can learn how you can target each element.

This is a tutorial you can follow: How to Use Your Browser’s Inspect Element Tool to Edit Webpages

when i submit nothing going to moralis database !! hence nothing on the page. but he polygon transaction is recorded on moralis database. no error to compile, any suggestion? what is wrong?