Authentication problem on Deployed Boilerplate

I have a problem: while authenticating with MetasMask on localhost:3000 I have no problem. When I deploy the Dapp, I authenticate with MetasMask, but after authenticating and signing I get no data on the tables while on localhost is working…

any specific error in browser console? can you look in network tab to see if there are requests that are made or failing?

I am getting this on the browser console when I connect to Metamask, and then sign

it looks like t can not access that server

My server is on Ethereum Mainnet Frankfurt. Any guess?

when you run it locally it has same config and it works fine? and when you deploy it somewhere it can not access same server url?

Exactly. I dont know if I should change location or not. Im confused

that error looks like something is blocking the access to that server url, but you should get same error when you run it locally

This is the Warning that I get running it locally:

where did you deploy it and it was not running on localhost?

deployed at:

and not running on localhost

are you sure that server is still running? that is the server that it tries to access

it is running, but the server is: right?

it looks like it tries to connect to a different server, you could update the code for server url and app id

I have tried many times but it always tries to connect to the same server (, this server does not exist) no matter what the SERVER_URL I type. I tried flushing the DNS cache and sockets cache but it doesn’t work

it may be related to deploy, or some env variable somewhere, that server should be from the code

Thank you!! I checked (a task that I should have done earlier) and it what hard coded in some JavaScript files. Now everything is up and running! It took me a while to find out. Thank you @cryptokid

1 Like