After moralis update, event listeners stop working

I have an event listener that listens to new minted NFTS in an ERC1155 and adds them to the database.
It worked fine a few days ago, and then I saw a new Moralis update and it suddenly stopped workding. I think that maybe it’s related to the update, but I’m not sure.
My sever URL: https://khufjkgozqta.usemoralis.com:2053/server

on what kind of update are you referring?

The one that shows up here. A while ago it was 0.0.288

now latest version is 0.0.290, can you try with latest version to see if it works ok?

Allright. Just a moment.

Yeah, it still doesn’t work.
I minted a new NFT, when I query it via web3 through the contract, it comes:

But it is not saved on moralis databse. I will have to reset it then

OK, I remade the contract and deployed it again, setted the envetSync. Let’s see how long it takes for it to stop working.

For now it works fine. Maybe it was my fault that it stopped wokring, but I have a feeling that it wasn’t. I just woke up one day and it wasn’t working anymore.

1 Like