Accessing Moralis database creates "MetaMask Phishing Detection"

Is this happening only for me?

This seems to be only an issue with Brave browser and MetaMask extension - it’s been reported to their team. You can just click continue.


Happened to me too as @alex said Brave browser.

1 Like

For temporary fix update the extension setting to this.


It looks like it is happening when using latest version of MetaMask extension, not only in brave browser

@rio, if you want we can change the server url for your server to another domain, after that you should not see that warning any more, but if you are using the server url hardcoded somewhere then you will have to change it with the new server url

Hey, thanks for the update. I can keep the server url for now.

1 Like

Me too,l I just got it. Using Brave and Metamask.

When I mentioned the danger of blacklists today in the Moralis Hackathon Opening ceremony, people thought something was wrong with me.

Can’t necessarily just continue. If a user is running JavaScript that accesses the Dapp, are they going to also get that warning? That’s an App Killer…

I’m using the appId and serverUrl in all my code, I can easily change that. How can I get around this without resetting my database completely?

You can read 2 replies above.

From what we know now only when you try to access the database dashboard you get that warning. And that happens also only if you enabled MetaMask to be active on any website.

Metamask must have discovered Ivans scam tokens on bsc from 2017…

It is happening in my chrome browser as well.

hmm yes, Apparently it is happening with the latest version of the metamask extension.

I can confirm it’s happening on Firefox too. So I guess it is Metamask related indeed.