520 Server Error - past 2 days (2/16/22-2/18/22)

Hey, [email protected] suggested I post here for assistance.

I have been running some code for about 2 months- the same code, nothing has changed. I have been using Moralis for about that same amount of time as my endpoints for interfacing with Fantom and Avalanche. Everything has worked flawlessly.

Starting two days ago I have received the following error, and now I get it within an hour of restarting my code. What is happening? The error says:

requests.exceptions.HTTPError: 520 Server Error: for url: https://speedy-nodes-nyc.moralis.io/~~~~/fantom/mainnet

(or /avalanche/mainnet)

I wasnโ€™t sure if my speedynode endpoint was account specific so I removed it from the URL.

It looks like the error is originating from a getReserves function call on an LP pair.


You could try separately that code that uses the speedy node url to see if it works

What? The issue seems to be with the speedynode endpoint- everything was working fine before. Tom said that speedynodes are being deprecated, but not quite yet. Should they be working or not? Should I just give up and look for another service?

we donโ€™t know if is a problem from speedy nodes or something else, you can also try another service to see if it works fine for your

speedy nodes should be working now

Ok, except since 2/16 they are not working for me. And nothing else has changed. Previously they worked for like 1.5-2 months straight. This is what I am looking for help with. What does the 520 server error mean?

I donโ€™t know, can you share code that replicates the problem?

Can you also send me in DM your email and speedy node url to check if it works?

Thanks, I sent you a DM!

that speedy node url seems to work for me, at least for basic commands like getting last block number

how do you run that code? if it is from browser, can you look in network tab to see what it is sent to the node via RPC and what is the response?

It works fine for about 2-30 minutes but inevitably eventually gives that response. I run python just directly from cmd

Can you retry when you get that error to see if it works?

Right. After I get the error I re-start the code and its fine again for 2-30 minutes then eventually gives that response again.

Maybe you can make it work without restarting the code